Nextcloud no longer reachable - Update needed (family about to kill me!)

Some thing seems to have gone wrong when upgrading my Nextcloud docker stack. It seems a new image is now being used, and my Nextcloud is no longer reachable. All I see is the following message in the web interface:

Update needed

Please use the command line updater because updating via browser is disabled in your config.php.

This is a huge problem and my family is about to kill me :wink:
I already tried to set ‘upgrade.disable-web’ => false, in the config, but the message remains the same.

How can I do this upgrade via the command line?
Please help!

Hello @BerndBop
In the Nextcloud Admin Manual you will find some occ commands about upgrading with explanations. These commands can be executed with the console. You only need SSH access to the server.

Here is the command you should execute:

sudo -u www-data php occ upgrade -v

Best regards, @nihe

1 Like

Hi nihe, thank’s for the input :slight_smile:

Since I’m using Docker, I’m not sure were/how to issue that command. On the server running Docker? Probably not.
In the Nextcloud container? Does not work:

root@605df339b705:/var/www/html# sudo -u www-data php occ upgrade -v
bash: sudo: command not found

I guess this is probably really simple, but right now I’m clueless…

Please enter the docker container with user www-data:

# Go into the container
sudo docker exec --user www-data -it your-nc bash

and try this:

php /path/to/nc-datadirectory/occ upgrade -v

Hope it works :grinning:.

1 Like

It worked. Everything back up and running again.
Thank you so much :slight_smile:

1 Like

Hello nihe!
I had the same issue this morning.
Thank you !!! You saved our lifes !!! :wink:

Great to hear that I was able to help :smile:

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.