Nextcloud nach PHP Update von 7.2 auf 7.4 nicht mehr erreichbar

Hey,
ich habe gerade ein Nextcloud PHP 7.2 auf 7.4 eingespielt. Nach dem Neustart kann ich die Nextcloud nicht mehr erreichen. Es erscheint die Meldung.

Kann mir jemand weiterhelfen?

Was für ein PHP verwendest du denn? mod_php, php-fpm ?
Steht was im apache error log ?

Ich hatte die gleiche Meldung (aber die Meldung ist so generisch, dass das nicht wirklich aussagekräftig ist). Schaue mal hier ob das etwas bringt: Can't get the upgrade from php7.2 to php7.4 to work

Es müsste php-fpm sein

Im error log steht.

[Mon Oct 12 21:06:31.845854 2020] [proxy:error] [pid 7309] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /run/php/php7.2-fpm.nextcloud.sock () failed
[Mon Oct 12 21:06:31.845899 2020] [proxy_fcgi:error] [pid 7309] [client 10.14.11.1:43170] AH01079: failed to make connection to backend: httpd-UDS
[Mon Oct 12 21:07:27.465445 2020] [mpm_prefork:notice] [pid 7304] AH00169: caught SIGTERM, shutting down
[Mon Oct 12 21:07:57.093512 2020] [ssl:warn] [pid 1936] AH01909: 127.0.1.1:443:0 server certificate does NOT include an ID which matches the server name
[Mon Oct 12 21:07:57.234255 2020] [ssl:warn] [pid 1962] AH01909: 127.0.1.1:443:0 server certificate does NOT include an ID which matches the server name
[Mon Oct 12 21:07:57.234331 2020] [http2:warn] [pid 1962] AH10034: The mpm module (prefork.c) is not supported by mod_http2. The mpm determines how things are processed in your server. HTTP/2 has more demands in this regard and the currently selected mpm will just not do. This is an advisory warning. Your server will continue to work, but the HTTP/2 protocol will be inactive.
[Mon Oct 12 21:07:59.543162 2020] [mpm_prefork:notice] [pid 1962] AH00163: Apache/2.4.29 (Ubuntu) OpenSSL/1.1.1 configured – resuming normal operations
[Mon Oct 12 21:07:59.543204 2020] [core:notice] [pid 1962] AH00094: Command line: ‘/usr/sbin/apache2’
[Mon Oct 12 21:10:25.718450 2020] [proxy:error] [pid 2009] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /run/php/php7.2-fpm.nextcloud.sock (
) failed
[Mon Oct 12 21:10:25.718508 2020] [proxy_fcgi:error] [pid 2009] [client 10.14.11.1:43173] AH01079: failed to make connection to backend: httpd-UDS
[Mon Oct 12 21:10:27.391956 2020] [proxy:error] [pid 2016] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /run/php/php7.2-fpm.nextcloud.sock () failed
[Mon Oct 12 21:10:27.392002 2020] [proxy_fcgi:error] [pid 2016] [client 10.14.11.1:43174] AH01079: failed to make connection to backend: httpd-UDS
[Mon Oct 12 21:19:50.671589 2020] [proxy:error] [pid 2022] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /run/php/php7.2-fpm.nextcloud.sock (
) failed
[Mon Oct 12 21:19:50.671660 2020] [proxy_fcgi:error] [pid 2022] [client 10.14.11.1:43180] AH01079: failed to make connection to backend: httpd-UDS

Was ist konfiguriert in /etc/apache2/sites-enabled/nextcloud…conf?

<FilesMatch "\.php$">
    SetHandler "proxy:unix:/run/php/php7.4-fpm.nextcloud.sock|fcgi://localhost"
</FilesMatch>

Was ist output von “php -version”?

PHP 7.4.8 (cli) (built: Jul 13 2020 16:46:22) ( NTS )
Copyright © The PHP Group
Zend Engine v3.4.0, Copyright © Zend Technologies
with Zend OPcache v7.4.8, Copyright ©, by Zend Technologies

Was sagt: service php7.4-fpm status?

In /etc/apache2/sites-enabled/nextcloud…conf steht

<FilesMatch “.php$”>
SetHandler “proxy:unix:/run/php/php7.2-fpm.nextcloud.sock|fcgi://localhost”
/FilesMatch>

Was ist output von “php -version”?

2468

Was sagt: service php7.4-fpm status?
123

Hoffe die Angaben sind so richtig :wink:

OK, Nextcloud verwendet also noch PHP 7.2 (wegen nextcloud…conf).

Kannst du mal schauen ob dann service php7.2-fpm läuft?
service php7.2-fpm status

Was hast du alles in /etc/php für ordner?

Unter /etc/php liegen diese Ordner ab

246

Kann es sein, dass der Service php7.2 überhaupt nicht läuft ?

1234

So wie es aussieht, wurde zwar php 7.4 installiert, aber keine php Version läuft?!

Was sein muss

Versuche

image

Wie hast du es gemacht?

Habe die Installation gerade versucht

Ich bin nach dieser Anleitung im Netz vorgegangen

https://pastebin.com/e5yY80Hy

Dabei muss ich irgendwas falsch gemacht haben

Läuft es jetzt?

Läuft es jetzt?

Leider noch nicht

Hast du /etc/php/7.2/fpm/pool.d/nextcloud.conf auf /etc/php/7.4/fpm/pool.d/nextcloud.conf kopiert?
Nachher in nextcloud.conf Einträge mit 7.2 ändern in 7.4

Nein, da habe ich nichts angepasst. Wie meinst du das ?

Apache wird dann jetzt neu 7.4 verwenden wollen (wegen Eintrag in /etc/apache2/sites-enabled/nextcloud…conf).

<FilesMatch "\.php$">
    SetHandler "proxy:unix:/run/php/php7.4-fpm.nextcloud.sock|fcgi://localhost"
</FilesMatch>

PHP 7.4 muss dann ein socket haben, damit die 2 mit einander reden können.

In /etc/php/7.4/fpm/pool.d/nextcloud.conf:

root@lin-nextcloud:/etc/php/7.4/fpm/pool.d# more nextcloud.conf
[Nextcloud]
user = www-data
group = www-data
listen = /run/php/php"7.4"-fpm.nextcloud.sock
listen.owner = www-data
listen.group = www-data
listen.mode = 0660
pm = dynamic
; max_children is set dynamically with calculate_php_fpm()
pm.max_children = 65
pm.start_servers = 12
pm.min_spare_servers = 6
pm.max_spare_servers = 35
env[HOSTNAME] = lin-nextcloud
env[PATH] = /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin
env[TMP] = /tmp
env[TMPDIR] = /tmp
env[TEMP] = /tmp
security.limit_extensions = .php
php_admin_value [cgi.fix_pathinfo] = 1

; Optional
; pm.max_requests = 2000

Nach anpassen muss php7.4-fpm service neu gestartet werden

service php7.4-fpm restart

Die habe ich nicht

567

Es sollte eine geben in /etc/php/7.2/fpm/pool.d

Diese musst du auf /etc/php/7.4/fpm/pool.d kopieren und dann Inhalt anpassen

Über WinSCP lässt die Datei sich nicht kopieren, wie würde der Befehl über Putty lauten?

cp -p /etc/php/7.2/fpm/pool.d/nextcloud.conf /etc/php/7.4/fpm/pool.d

Jetzt bin ich etwas weiter, beim aufrufen von

service php7.4-fpm status

sieht es jetzt so aus

Aber erreichbar ist die Nextcloud weiterhin nicht ?!