Nextcloud Mobile iOS app keeps asking for password

ios
#1

Hi guys

Thanks for the great nextcloud product. A lot of hard work went into this problem and I appreciate it.

Here is my setup in case this helps
Nextcloud: 15.04
Hosted with FreeNAS 11.2-Release UI running within freebsd jail 11.2-Release p!
Apache webserver Apache/2.4.38 (FreeBSD)
iOS Nextcloud Mobile App 2.22.8
iOS 12.1.4

I’m having problems logging in with the mobile iOS app (I’m not having any problems logging in from computer or through browser on the iphone – just the mobile nextcloud iOS app).

I enter credentials and for a brief second I can see the files list and then I’m taken back to the login screen. It keeps occurring over and over again.

Within the nextcloud logs I get the following:

{"reqId":"XykabxYmbeC4ugWTfUPk","level":2,"time":"2019-02-15T15:50:24+00:00","remoteAddr":"24.13.24.199","user":"--","app":"core","method":"GET","url":"\/index.php\/login\/flow","message":"Renewing session token failed","userAgent":"Mozilla\/5.0 (iOS) Nextcloud-iOS\/2.22.8","version":"15.0.4.0"}

Is there anything I should be doing to help solve this problem

#2

There was a recent update to the nextcloud mobile app. I’ve updated to version 2.23.0.0 and the errors that were occurring as described in the original post do not occur anymore. Possibly the update fixed it.

Thanks.

#3

I also have this problem. nextcloud and app installed today therefore latest version. I’m going crazy.

#4

Hello,

please tell us your iOS version, your app version, your server version …

#5

I solved by adding these lines to the .htaccess file.

RewriteEngine On
RewriteCond %{HTTP:Authorization} ^(.)
RewriteRule .
- [e=HTTP_AUTHORIZATION:%1]

seems to be a problem with some php-fpm configurations

I was inspired by Client login fails with 401

Thanks

1 Like