Nextcloud Login Issue Google Chrome

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 17.01
Operating system and version (eg, Ubuntu 17.04): Ubuntu Server 18.04.3
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.29
PHP version (eg, 7.1): 7.2.24

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Attempt to login with any user account using the latest version of Chrome.
  2. The ‘cirlce’ will continue to spin and the user isn’t logged in.
  3. Hitting refresh in the browser allows the user to login.

The output of your Nextcloud log in Admin > Logging:

PASTE HERE

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

PASTE HERE

The output of your Apache/nginx/system log in /var/log/____:

PASTE HERE

When logging into Nextcloud with any user account using Chrome the circle continues spinning. Hitting refresh in the browser logs in the user.
This issue does not occur when using Firefox.

1 Like

Exact same issue for me!

Are you sat behind a reverse proxy? - I’m wondering if the issue is related to HAProxy (in my case) causing issues during the login redirection.

I fixed this issue by modifying my config.php as per a post on github.

I had a similar issue regarding the redirect , mine was related to url overwrite protocol option that should be set in config/config.php .
In previous version this was not necessary but apparently since 15.0.2 it is.
So I had to go from (config.php)
{...} 'overwrite.cli.url' => 'https://domain.lu', {...}
to
{...} 'overwrite.cli.url' => 'https://domain.lu', 'overwritehost' => 'domain.lu', 'overwriteprotocol' => 'https', {...}
This did the trick for me…
For information I’m running nextcloud docker behind a reverse proxy (which also handles ssl).
I have found the solution on this thread : nextcloud/server/13713

Hope it helps !

Logout still takes ages, but I believe that is being addressed in v18.

3 Likes

Wow, thats work for me, thanks