Nextcloud kubernetes apache conf

hello

i deploy via the helm chart a nextcloud instance via rancher
so i create the conf via the values.yaml
the instance works fine but i cannot upload more than 1MB , i got error , but nothing in the log
several people got this and the change LimitRequestBody in the apache conf

but how may update the apache file via the values.yaml , there is no input for that ?

Hello Florent_BITSCHY,

welcome to Nextcloud community.

can you please post more details how you setup nextcloud instance via rancher so we can help you ? Although in the Admin settings you can set the PHP size upload limit if I am not wrong.

hello vitachaos

thanks for replying

i install via this helm chart Nextcloud Helm Charts | helm

the nextcloud instance is working fine but i cannot upload fiel bigger than 1M

i saw on this post WebDav client Can't upload files >1 MB in NC15 - #8 by blackde5ert that i have to change LimitRequestBody in my apache file , but i have no idea how to do it via the values.yaml

cronjob:
annotations: {}
curlInsecure: false
enabled: true
failedJobsHistoryLimit: 5
image: {}
schedule: ‘*/5 * * * *’
successfulJobsHistoryLimit: 2
persistence:
enabled: true
storageClass: “standard”
internalDatabase:
enabled: true
name: nextcloud
nextcloud:
host: nextcloud.xxxxxxx.xxxxx
username: admin

configs:
custom.config.php: |-
<?php
$CONFIG = array (
‘overwriteprotocol’ => ‘https’,
‘overwrite.cli.url’ => ‘’,
‘filelocking.enabled’ => ‘true’,
‘loglevel’ => ‘3’,
‘enable_previews’ => false
);

mariadb:

Whether to deploy a mariadb server to satisfy the applications database requirements. To use an external database set this to false and configure the externalDatabase parameters

enabled: true

db:
name: nextcloud
user: nextcloud

persistence:
enabled: true
accessMode: ReadWriteOnce
size: 20Gi
redis:
enabled: true

usePassword: true

here are my values.yaml entry