Nextcloud - JavaScript Chat XMPP Setup

Hello the community of Nextcloud,

I am a French student.
I am in a project group, and to better organize ourselves, I started a project, it is to use a software free of right where we can have our own storage space, mail server, and a communication tool . (like Facebook)

I was interested in Nextcloud, I saw that it proposed these 3 functionalities.
I want to say that I am new to the Linux operating system.
I apologize for the awkward things I’m going to say
I launch into the unknown trying to follow tutorials on the internet.

For storage space, it’s done, it’s automatically there after installing Nextcloud.
However, our mail server is almost operational thanks to Postfix, dovecot.

However, I am really a novice in the installation of an XMPP server
I discovered your functionality of “JavaScript XMPP chat” which offered both instant messaging, and we can integrate a video conference! Very cool !

So I saw that you offer a tutorial.
I will have a few questions during the steps.
I will use both in the same server!

My config :

I would already like you to answer these questions, I am really a novice, I have already done some tests, but without success.
each time i have this message :

BOSH server NOT reachable error”

Thank you for reading, and for the help you will bring me

1 Like

Looks like you are trying to take five steps ahead on one.

First make sure your XMPP server is working through a regular client connection using a desktop client such as Pidgin.

Then make sure all your SSL certificates are working. I recommend reverse-proxying the BOSH url, but it should also work directly through the respective ports (make sure your firewall has those open though).

Last comes the cloud auth stuff that is very Nextcloud specific.

Thank you for your answer, I tried to continue but unsuccessfully, I have however some questions.

In the tutorial, during the configuration of Prosody:

Ssl = {

  •   Key = ‘’ /etc/prosody/certs/localhost.key ‘’ ;
  • Certificate = ‘’ /etc/prosody/certs/localhost.crt’’ ;
  • key = ‘’/etc/letsencrypt/live/’’ ;
    +certificate = “ /etc/letsencrypt/live/”;

so I have to have file “privkey.pem” + “fullchain.pem” However, I have to have a real domain name validated by the net? Because I use Bind9 for my domain name, because to reach my nextcloud, I put in the URL “http://projet.tut

I can make you a screen of my file of bind9

I tried to follow the tutoriel but in vain…

When I type the command:

" Letsencrypt d projet.tut d www.projet.tut m webmaster@projet.tut - Redirect - hsts uir "
She(It) turns(returns) me

" Certbot doesn’ t know how to automatically configures the Web to server one this system. However It can till get has certificate for you, please run certbot certonly " to doh so. You’ ll need to manually configures to your Web to server to uses(wears out) the resulting certificate "

Thus, I try to type " certbot certonly "

She returns me :

" How would you like to authenticate with The ACAME THAT? "

1: Place line in webroot directory ( webroot )
2: spin up has tempory webserver standalone

I don’t know what to do after this stage?

Conclusion :
Step 1 : Installing the software : OK
Step 2 : Setting up DNS entries : OK
Step 3 : Setting up Apache with a Let’s Encrypt certificate : Apache ok, but Let’s encrypt need help
Step 4 : Prosody : Not okay… I tried to modify the file " / etc. / prosody / prosody.cfg.lua “

Thanks for your anwser.

@Minahora we are sorry, but we don’t have enough man power to guide you through all steps to setup a server. If you have concrete questions to xmpp and our cloud auth module, please open an issue at

Hello @Minahora - this is a quite “complex” setup including the installation and setup of several services. I remember having tried this (XMPP server with NC) almost some 2 years ago, and it took me quite a time to bring it up. I then had to stop my attempt, because I didn’t have enough experience and ressources for setting up also a turn server, which is needed for video/audio being behind NAT. I only managed to setup a local TURN server some days ago for NC Talk -> TURN server for Nextcloud Talk

So it contains several issues - don’t be too frustrated, if nobody can deliver a quick all-in-one recipe, it’s about doing a lot of research, trial’n error :slight_smile:

  • Setup XMPP server
  • Setup NC server
  • Link both
  • Need for STUN/TURN server? User external or setup these yourself


We would love to provide such an issue installation guide, but there are to many different setups to cover them all. If you have a small installation, you may want to try our internal backend or you can try our new managed backend which is currently in beta stage.

1 Like

yes, i fully agree. it’s definitely doable but quite complex. how much time do you want to invest?
i also tried this a long time ago and quit; my main problem was nc and xmpp (ejabberd accessible natively) in different subdomains with ssl and i just could not get bosh/apache_mod_proxy to play nice with each other in this setup. the jsxc(or whatever it’s called)-page makes this look very easy, which in my case it me was not.
in a different project (just for fun) i was able to get jsxc to run on an internal non-ssl-ejabberd-server over plain http, but (in the end) it meant downloading their example-code and adapting almost each and every line of it.
i personally like ejabberd as an xmpp-server (although i haven’t tested anything else), it’s flexible, well-documented, not (too) hard to set up and has a very nice commandline-interface.

please be aware that you might create gaping security-holes if you run an internet-accessible server and treat any of the security-related things in this too lightly.

Thanks for your answer !
i’ll try again… and ask github

Hi! I have Centos7 and stuck on making xcauth from sources. Make install gives me strange output error:

if ! groups xcauth > /dev/null 2>&1; then \
          adduser --system --group --home /var/lib/xcauth --gecos "XMPP Cloud Authentication" xcauth; \
adduser: group '--home' does not exist
make: *** [install_users] Error 6

What may be done here? Thanks!

Please never post to such an old thread, because everyone will get an notification. The right place to report such an error would be Thanks

1 Like

looks like a syntax-error when invoking adduser.
adduser --help
man adduser
should reveal the syntax to you.

1 Like