NextCloud is painfully slow and the desktop client disconnects before making it through a scanning operation

Nextcloud version (eg, 12.0.2): 15.0.12.1
Operating system and version (eg, Ubuntu 17.04): Ubuntu Desktop 18.04
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.29 (Ubuntu)
PHP version (eg, 7.1): 7.2

I have searched and tweaked but my NextCloud install is abysmally slow and constantly drops connection. The website is painfully slow and the desktop app won’t sync as it errors out with some framesize buffer error, or it simply disconnects before the sync can complete. When looking at my Unifi logs I can see that neither the host machine or the client machine have lost connection.

I have dnsmasq on my pi-hole install sending my NextCloud traffic internally so I’m not going outside and back.

Here are all (I think) my relevant config files:

It’s probably wort noting that this notice shows up in the settings page:

The "Strict-Transport-Security" HTTP header is not set to at least "15552000" seconds. For enhanced security, it is recommended to enable HSTS as described in the security tips

The only one I’m not quite sure about is my mysqld.cnf. It seems a bit light, but none of the other files in locations spit out by mysqladmin --help had anything in them.

Please help. I’m quite fond of NextCloud and really don’t want to switch to Seafile, but this is unusable.

I’m hoping it’s a result of my noobness and something relatively straightforward. Any help is appreciated!

Somebody? Anybody?

What are you running it on? Also if you could, post your Apache site config.

also check that redis is actually working (How to check if Redis is used in NC).
When I activated it everything sped up significantly. You could also try updating and make sure to check the recommendations in the settings.

What kind of machine do you have? And what is slow, if you upload a lot of stuff or already the web interface?

Caching has a huge impact on performance, for the database, there is a bit of background:

I speed up mine especially for uploads: MySQL analyse tools and performance recommendations

If it is not just slow and you have errors, there is probably something else wrong as well. Framesize buffers errors don’t look good. By the way, NC 15 just went out of support, you should consider upgrading to a supported version (e.g. NC 16). Wait for NC 18 at least for the next point-release.

redis is definitely running. I monitored it and just loading the cloudflare web UI gave me more than 10k lines that look like this.

It’s running on a bare-metal HP EliteDesk 800 G4 Mini with an i5-8500T, 16GB RAM, and a 250GB NVMe drive for OS+LAMP. The data directory is on a RAID1 array attached via USB3.0 that clocks in around 5Gbps.

I’ve edited the original post to include my apache site config files.

As for what is slow, the web UI is slow, scanning for changes in the Windows app seems slow but most importantly, it will not complete a sync do to either a timeout or some frame size error.

Such information is good at the start. We sometimes have users with a raspberry pi who complain that they do not reach 100 Mbit/s. :wink:

Do you manage to get you error by just using the web-interface? This way you could focus on that and try to find the framesize buffer error first.
In case you have apache’s webdav module installed, make sure it is not used in the Nextcloud config: https://docs.nextcloud.com/server/18/admin_manual/installation/source_installation.html#apache-web-server-configuration

Another thing, when you access and it takes time, check which processes (database, php) block the loading, is it CPU, i/o performance.