Nextcloud instance is not accessible on the host server or using the DNS

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version : 28.0.2
Operating system and version : openmediavault 6.1.0-0.deb11.13-amd6

For my NAS setup, I have OMV installed on which a stack comprising Nextcloud, mariadb and letsencrypt containers are running. I used duckdns to register a domain and mapped that to my public IP.
I have been able to use the setup to upload my files to Nextcloud successfully for about a couple of months now.
Last week, all of a sudden nextcloud stopped working on browsers within my home network or external with the “Internal server error”.

When I looked at the nextcloud.log within my nextcloud container, I noticed that there was a php memory allocation error. So I increased the memory limit and no longer see that error. There were some warnings from a few apps (Mail, Richtextdocument and Recognize) and I disabled all of them.

I redeployed the stack but still cant get it working.

When I tried access the nextcloud service from the letsencrypt container, using curl command, it returned the html for my login page successfully.

However, when I tried to access it from the host using curl -I https://<dns>:443, it returns a default html page that indicates webpage is being constructed.

Things that I have checked so far

  • Letsencrypt has port forwarding for 443 on the container to the host
  • Port 443 is enabled to forward on my router
  • My host has internet access
  • Duckdns resolution from my host is correctly pointing to my public IP
  • Public IP address has not changed
  • the nextcloud.log does not have any error
  • the ngingx error and access log on letsencrypt container does not contain any error either.

I am a total noob to this and setup everything following instructions from multiple sites in the first place. Networking is not my strongest suit either. So I have spent a week now trying to understand the issue but couldnt understand what is wrong or where to look for more data.

Any help would be highly appreciated.