Nextcloud installation not honoring php.ini

Good afternoon all, here are my system specs:

OS: Debian Buster
Mem: >8G
Cores: 4

Nextcloud 18.0.6

Apparently the installation isn’t honoring the values in /etc/php/7.3/apache2/php.ini.

These are

memory_limit = 524M
upload_max_filesize = 32M
post_max_size = 32M

These values are verified with calling phpinfo.

On the NC control panel I’m getting a “memory below 512MB” warning, and on the server info tab

Version: 7.3.14 (<—correct)
Memory Limit: 128 MB
Upload max size: 2 MB

It appears that Nextcloud is ignoring the settings in /etc/php/7.3/apache2/php.ini or overriding them.

Any input would be appreciated.

If you are using apache, it can be a .htaccess file in the main directory or the parent directory (if you are running Nextcloud in a subfolder). If you are in the same virtualhost like the Nextcloud setup, the phpinfo should give you the right settings.

Fixed - it was a php-fpm misconfiguration. Thanks for your input anyway.