NextCloud in Docker example not working

Hi Experts,

I followed this link exactly:

in Ubuntu 20.04LTS (fresh ubuntu with docker and docker-compose, nothing else).
I filled ‘VIRTUAL_HOST=’, ‘LETSENCRYPT_HOST=’, ‘LETSENCRYPT_EMAIL=’, ‘MYSQL_ROOT_PASSWORD=’, in docker-compose.yml. Also fields in db.env.
Then run docker-compose build --pull.
docker-compose up -d
Installation went ok.
But when I browse https://127.0.0.1, I got site un-safe, hit continue the I got:

503 Service Temporarily Unavailable

Tried from internet with Chrome, got NET::ERR_CERT_AUTHORITY_INVALID. Tried ssltest, it said my domain name not in the certificate.

I did get the in-secure one working though.

What am I missing please? Thanks a lot.

You will always get a certificate error when using an IP address because it will never match the name on the certificate. The domain name typed in the address bar must match a name on the certificate for it to be considered valid.

Use the same name you registered on the certificate instead of the IP.

@KarlF12,
Thanks for your response!

I tried https://myname.freemyip.com (is a Dynamic DNS, it is in my docker-compose.yml)
And I got: Your connection is not private. NET::ERR_CERT_AUTHORITY_INVALID.
Tested https://myname.freemyip.com with ssllab, and I got:
Alternative names - INVALID
Trusted No

BTW, I don’t see config.php file, googled it and people saying it will only be created after I log in.

Is it possible that I filled ‘VIRTUAL_HOST=’, ‘LETSENCRYPT_HOST=’, ‘LETSENCRYPT_EMAIL=’ wrong?
Should the _HOST be my dynamic DNS, _email be my personal email address?

:smiling_face_with_three_hearts:
Ok, problem solved!
It was caused by the Dynamic DNS, I can ping my domain but not browse.
Switched to a different one, it is working now!

Thanks for the help!