Nextcloud http access with error

Hello everyone!
I’m a cloud novice.

I need help with this wonderful cloud.
I researched everything and I can’t find anything about the HTTP domain configuration.
I can get external access from my cloud via http: // ip: 8080 / nextcloud.
But I can’t access http: //

Error page!

I already released the ports on the router, I already released the Firewall,

I need NO-IP access, because I can mask my ip, because I will share my cloud with friends.

Can someone help me?

I think we need more details. Why do you use only HTTP and not HTTPS and why do you use port 8080 and not 443 ? If you use DynDNS, Port-Forwarding and the ports 80 (http) and 443 (https) it could better work. Please notice that you need port 80 not for nextcloud but for configure Lets Encrypt for TLS/SSL on port 443. Read manuals.

Hello, thank you very much for responding.

I’m using HTTP because I want to use nothing important for just a few friends. If HTTP access by domain works, then I can try to create an HTTPS certificate because I don’t know how to do it yet.

I already tried port 80 and 8080 configuring the router and NO-IP, because they are HTTP right? Is port 443 HTTPS correct?

I’m going to reread the manuals, to see that port 80 issue.

The strange thing is that I have access by ip without any problem, example: http: // meu_ip: 8080 / nextcloud

But I do not have access by NO-IP even configuring it on the site (meu_ip: 8080) with the ports correctly, example:

It seems to be a lock inside the nextcloud folder that lets the IP access but does not leave the domain.

I’ve tried to add the address on overwrite.cli.url to no avail.

Why do you use port 8080 for the service and not 80? That make mostly no sense.

I put the 8080 because on port 80 the same problem happens.
I can go back with the 80 masso error continues.