Nextcloud fediverse (accessing fediverse)

I have installed Nextcloud 19.0.1 on Ubuntu Server via snap and am trying to access the fediverse with the Social app.

When I go to the app in my server my social address is @user@localipaddress

There is a message at the top that says:

.well-known/webfinger isn’t properly set up!

Social needs the .well-known automatic discovery to be properly set up. If Nextcloud is not installed in the root of the domain, it is often the case that Nextcloud can’t configure this automatically. To use Social, the admin of this Nextcloud instance needs to manually configure the .well-known redirects: Open documentation :arrow_upper_right:

However this documentation is very confusing and does not seem to mention social at all.

I did find a way to access Nextcloud console (occ) in the terminal and used the command:
sudo nextcloud.occ social:check:install
Which returned:

My goal is to be able to both follow and post to the fediverse
And I can’t seem to figure out how to change the cloud_url, social_url, or “social_address”
which hopefully will make it work.

do you have an existing fully qualified domainname setup?
like cloud.domain.tld?

and do you have a valid certificate for that one?

as far as i know you can’t set your social-address yourself. system picks it from your setup.

as for that problem… go and follow the documentation or search the forum on that. there are existing solutions for that problem

Thanks for the quick reply :slight_smile:

Yes, due to limitations of my ISP I had to go with self-signed signature. To access my server on a browser I need to enter:
https://cloud.domain.tld:444

I have been searching but the documentation doesn’t make much sense to me and doesn’t point to an obvious config file.
It does mention a file called:
.htaccess
but it seems to suggest that I need to be in a subfolder for it to help.
I am using an installation from a snap package, and I don’t believe that i’m in a subfolder.

One interesting observation is that one of the users on my server couldn’t connect via the Nextcloud Talk IOS app even though the same address worked for on android.
It seems like this is a related issue.

i’m far from being a pro in that matters… but your problem really could come from your self-signed certificate.
though you can apply for a offical let’sencrypt certificate as well… even with uncommon ports opened. … apart from the LE-manual there are several solutions for that on the forum as well.

and it might happen that an iOS device would be more picky about self-signed certificate as an android-one.

I was wondering that myself.
I will certainly look into applying for the lets-encrypt certificate on uncommon ports. That would be really helpful for me. I know the snap package has a built in lets-encrypt function but I’m sure I could find a way to manually work around that.

For now I’ll keep searching for a way to get nextcloud social to display a different IP/URL.

I am having the exact same problem: no social address and the webfinger error.

The documentation is horrific and seems to assume you have an nginx.conf that contains all kinds of references to .well-known, mine does not. I tried adding the “rewrite” line as stated here :https://github.com/nextcloud/social/issues/294 but it does not seem to help.

My install is on a Ubuntu 17 system, with a dedicated install. I also have my domain setup at the root level with valid Let’s Encrypt certificates.

I hope someone can help with this. The idea seems great, to have all your Fediverse linked to your Nextcloud. But if it is not working it will never gain traction…

1 Like

Me too. NC 19.0.2 and Social app 0.3.1

I don’t understand why they deliver software without a documentation :frowning:

Why they did not add the webfinger stuff to the Social app?

the still open bug on GH would mark the thread “solved” (not in a good way, though) for the forum, I’m afraid.

But I can see something being worked on here --> https://github.com/nextcloud/social/issues/976

if someone has found a workaround pls post it under issue/294