Nextcloud fails to launch using PHP 7.3

Nextcloud version 15.0.8
Operating system and version Ubuntu 18.04
Apache or nginx version Apache 2.4.29
PHP version 7.3

The issue you are facing:
Getting this error in PHP Log. I’ve tried updating to 7.2 and 7.3 and get this same error. I want to move to NC 16, so I’m breaking it with this until I find a solution. Any help is appreciated.

[Sat Jul 06 01:22:31.530928 2019] [php7:error] [pid 2350] [client] PHP Fatal error:  Uncaught Doctrine\\DBAL\\DBALException: Failed to connect to the database: An exception occured in driver: could not find driver in /var/www/nextcloud/lib/private/DB/Connection.php:64\nStack trace:\n#0 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): OC\\DB\\Connection->connect()\n#1 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\\DBAL\\Connection->getDatabasePlatformVersion()\n#2 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(328): Doctrine\\DBAL\\Connection->detectDatabasePlatform()\n#3 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(623): Doctrine\\DBAL\\Connection->getDatabasePlatform()\n#4 /var/www/nextcloud/lib/private/DB/Connection.php(151): Doctrine\\DBAL\\Connection->setTransactionIsolation(2)\n#5 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/DriverManager.php(172): OC\\DB\\Connection->__construct(Array, Object(Doctrine\\DBAL\\Driver\\PDOMySql\\Driver), Object(Doctrine\\DBAL\\Configura in /var/www/nextcloud/lib/private/DB/Connection.php on line 64
[Sat Jul 06 01:22:46.717420 2019] [mpm_prefork:notice] [pid 2311] AH00169: caught SIGTERM, shutting down

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it:

  1. Run Nextcloud 15 using PHP 7.0
  2. Change PHP Version to higher than 7.0

The output of your Nextcloud log in Admin > Logging: Nextcloud won’t launch

The output of your config.php: Config file was unchanged - only PHP version changed.

The output of your Apache log: Pasted above

You php 7.3 install misses the required database driver. You need to install the php driver modules for your database.

Fixed all Apache modules and warnings but was still hit with the Internal Server error. Looked into the NC log and the issue was the php7.3-redis module was missing. It’s fixed now.

Thanks for your help!