Nextcloud - failed tried once more to Start with Nextcloud Office

Nextcloud 25.0.5
NGINX as reverse proxy infront of an apache installation. All other is working fine.
How are the urls constructed because this is somehow horribly wrong:

Normal URL of the Server https://homeserver.domain.tld/
nextcloud.log CURL 7 Error after installing Collabora & Nextcloud office: Timeout on URL
which should be:
Answer here:


So wrong Protocol & wrong url (missing apps)

tried it in multiple versions in past never analyzed it.

looks like the Appimage (apps/richdocumentscode/collabora/Collabora_Online.AppImage) doesn’t have the settings for SSL Termination etc…

at least a check with
./Collabora_Online.AppImage --appimage-mount
shows that ssl termination is false

I think there are to less options to set if a reverse proxy is used in front of nextcloud.

hi @katamadone welcome to the forum :handshake:

please review your reverse proxy settings… you should have this 3 set


thanks for the answer.
these are in:

this not:

I’ll eventuelly check back, but I’ll first end-test my podman solution

One important knowledge sharing. If the nextcloud instance is not reacting anymore because of wrong settings and timeouts. It’s the easiest way to get to the database and delete the two urls.