Nextcloud end of configuration

Hello everyone,

I’m a complete beginner in the world of servers.
raspberrypi 4 8GO - Debian 12

I just installed:
Apache2 Web Server
UFW
PHP 8.2
MariaDB Server
Nextcloud Source Code

By following How to Install Nextcloud on Debian 12

I can’t connect to my nextcloud

Your data directory is invalid. Make sure the data directory contains a ".ocdata" file at its root. Unable to create folder "data". This problem is usually solved by giving the web server write access to the root directory. See https://docs.nextcloud.com/server/27/go...ermissions

I don’t know anything about that guide (and the link didn’t work), but you may want to compare the process in it to the one in the official Admin Manual:

Also, did you look at the link mentioned in the error?

Generally it’s a permissions, folder ownership, or path matter associated with your configured datadirectory as defined in your config.php.

Did you try to add an emty .ocdata file to your datadirectories root?

Thanks to everyone who tried to help me.
I did a new installation: GitHub - nextcloud/nextcloudpi: 📦 Build code for NextcloudPi: Raspberry Pi, Odroid, Rock64, Docker, curl installer...

  • Raspberry Pi OS/Debian 11 (Bullseye)
    -Nextcloud
  • Apache, with HTTP2 enabled
    -PHP 8.1
    -MariaDB
  • Redis memory cache
  • ncp-config TUI for easy setup (RAM logs, USB drive and more)
  • Automatic redirection to HTTPS
  • APCu PHP cache
  • PHP Zend OPcache enabled with file cache
    -HSTS
  • Cron jobs for Nextcloud
  • Sane configuration defaults
  • Full emoji support
  • Postfix email
    -Secure

Currently I am in Warnings on admin page

And I want to resolve : "Your installation does not have a default region prefix. This is necessary to validate phone numbers in profile settings without a country code. To allow numbers without a country code, please add “default_phone_region” with the region’s respective ISO 3166-1 code in your configuration file.’

with:

[18:57:49] root@nextcloudpi: /  # sudo -u www-data php /var/www/nextcloud/occ config:system:set default_phone_region --value="FR"
This version of Nextcloud is not compatible with PHP>=8.3.<br/>You are currently running 8.3.0.[19:16:30] root@nextcloudpi: /  #

Et : The PHP module “imagick” is not active but the Theming application is activated. For Favicon generation to work correctly, this module must be installed and active.

I installed php-imagick and libmagickcore-6.q16-6-extra

you must write not stick
‘default_phone_region’ => ‘FR’, => /var/www/nextcloud/config/config.php
Resolved

A new problem :

[ nc-admin ] (Tue Dec 12 21:20:20 CET 2023)
This version of Nextcloud is not compatible with PHP>=8.3.<br/>You are currently running 8.3.0.

Resolved

[22:25:18] root@nextcloudpi: /  # update-alternatives --config php
There are 2 choices for the alternative php (providing /usr/bin/php).

  Selection    Path             Priority   Status
------------------------------------------------------------
* 0            /usr/bin/php8.3   83        auto mode
  1            /usr/bin/php8.1   81        manual mode
  2            /usr/bin/php8.3   83        manual mode

Press <enter> to keep the current choice[*], or type selection number: 1
update-alternatives: using /usr/bin/php8.1 to provide /usr/bin/php (php) in manual mode
[22:28:19] root@nextcloudpi: /  # php --version
PHP 8.1.26 (cli) (built: Nov 24 2023 13:12:14) (NTS)
Copyright (c) The PHP Group
Zend Engine v4.1.26, Copyright (c) Zend Technologies
    with Zend OPcache v8.1.26, Copyright (c), by Zend Technologies

Expected file size: 234221 bytes but file size read (from Nextcloud client) and written (to Nextcloud storage): 8192 bytes. This could be a network issue at the client level or a storage issue at the server level.

Resolved

add at the end of : /etc/apache2/apache2.conf

<IfModule reqtimeout_module>
  RequestReadTimeout header=0
  RequestReadTimeout body=0
</IfModule>

I am closing because I am starting again with a new and classic installation

You could also try nextcloudpi.com for an image that is built on Debian with btrfs filesystem backups and such. Uses apache2.

1 Like

Seen too late I installed a debian 12

I made too many connection attempts, how do I start from the beginning?

Install NextcloudPi if you are stuck. It will handle all of this for you.

1 Like

Last background job execution ran 5 hours ago. Something seems wrong. [Check the background job settings ]
(http://192.168.1.58/index.php/settings/admin#backgroundjobs)

[15:16:20] root@debian: /  # crontab -u www-data -e
No modification made
[15:16:42] root@debian: /  # crontab -u www-data -l
*/5  *  *  *  * php -f /var/www/html/cron.php
[15:16:52] root@debian: /  # 

alias nextcloud=‘cd /var/www/html’

[15:18:53] root@debian: /  # nextcloud              
[15:19:02] root@debian: /var/www/html  # ls
3rdparty  AUTHORS        composer.lock  console.php  core      data  index.html  lib            occ  ocs-provider  package-lock.json  remote.php  robots.txt  themes   version.php
apps      composer.json  config         COPYING      cron.php  dist  index.php   nextcloud.log  ocs  package.json  public.php         resources   status.php  updater

[14:21:25] root@debian: /  # sudo -u www-data php /var/www/html/occ maintenance:update:htaccess
An unhandled exception has been thrown:
OCP\HintException: [0]: Memcache OC\Memcache\APCu not available for local cache (Is the matching PHP module installed and enabled?)

nextcloudpi

How do I put the menu in English?

aborted

Hello everyone,
Everything works perfectly
except that I am connected in http and not in https
please guide me

System Info

System Info

How I should upgrade to latest Debian/Raspbian?
Can or should I wait?

Welcome to nextcloudpi!
As you can see in your own post the learning curve is steep.

Unfortunately we as volunteers can’t see your setup in person. Therefore it is necessary that you describe your issues as good as possible.

The ncp webui should a self signed certificate and should connect with https. If you are talking about your nextcloud webpage you should add a certificate to your server/domain. You can do this with the tools of ncp. The web ui should have a section with let’s encrypt.

Debian 12 is not supported yet by nextcloudpi. The maintainer(s) are working on that.

1 Like

Thank you for your welcome
I’m new to the world of servers
Here is the page

Domain : ip of nextcloud server => ok

Additional domain : external ip of my box => ?

Email : that I find in /index.php/settings/admin

Both ports 80 and 443 need to be accessible from the internet => I know how to do

How I access the address indicated in /index.php/settings/admin

[ letsencrypt ] (Sat Dec 16 20:09:59 CET 2023)
Requested name “xxxxx” is an IP address. The Let’s Encrypt certificate authority will not issue certificates for a bare IP address.
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /tmp/certbot-log-ttrqjas4/log or re-run Certbot with -v for more details.