Nextcloud email settings problem

Hei,
i tryng nextcloud first time.
I have one problem with email settings ( smtp )
When i fill the necessary fields ( all mail settings are correct ), then tryng to send test mail.
I get this error message:

A problem occurred while sending the email. Please revise your settings. (Error: Connection could not be established with host myhostname [ #0])

Nextcloud log sayng this error:
[authz_core:error] [pid 4725] [client IPaddress:56668] AH01630: client denied by server configuration: /var/www/nextcloud/data/htaccesstest.txt

Server configuration:
ubuntu server 14.04.5
Apache version 2.4
PHP 7.0
Nextcloud version 10.0

I would be very thankful if i find the solution to the problem.
have a nice day :slight_smile:

Can you put this in your config/config.php in order to get more details in your logs:

/**
 * Enable SMTP class debugging.
 */

'mail_smtpdebug' => true,

If you control the mail server as well, you can check the logfiles there as well.

Hei,
i add ‘mail_smtpdebug’ => true, in my config.php.
Where i see more information?
I see my apache site log /var/www/apache2/pilv_error.log and /var/www/apache2/error.log
Admin panel see same error log:
A problem occurred while sending the email. Please revise your settings. (Error: Connection could not be established with host mail.addit.ee [ #0])

Are you sending through php? Or smtp?
The new log-option should create entries in your Nextcloud-logfile.

Hei,
i send mail over smtp.
I see my mailserver this error:
warning: TLS library problem: error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca:s3_pkt.c:1263:SSL alert number 48

there seems to be a problem with the certificate:
https://ssl-tools.net/mailservers/addit.ee

Hey,
Thank you, i found solution :slight_smile:

Would be nice to let others know what your solution was.

Hei,
my solution are here:

i add my postfix conf my CA cert file.
ubuntu server 16.04 location /etc/postfix/main.cf
And i add this line in TLS parameters:

TLS parameters
smtpd_tls_CAfile = /etc/ssl/certs/CAfile.crt

its worked for me :slight_smile:

2 Likes

I was using the cert.pem instead of the fullchain.pem (From letsencrypt) on my mailserver and got this error. You can check your emailserver here: www.sslshopper.com

Working without problem using the fullchain.pem

1 Like

For those who would like to use smtp.gmail.com (after setting at myaccount.google.com ), port 587 did not work but port 465 worked when “Encryption: SSL/TLS” is chosen at “Email server” setting of Nextcloud.

In fact, www.sslshopper.com/ssl-checker.html#hostname=smtp.gmail.com:587 showed “No SSL”, but 465 displayed its certificate info.

2 Likes

Hi, I also simply changed port to 465 and it is working, can someone explan maybe? Thanks