Nextcloud does not scan Folder that is Changed not by Nextcloud

Hi,
I have an external storage that is connected by smb on a Windowsshare. If it is changed externaly (eg with my Scanner that puts there some pdf) it will not be recognized by Nextcloud.
Can you help me to fix that?

Steps to replicate it:

  1. Copy Files with Windows to the Nextcloud Share directly over SMB and not Nextcloud (or E.G. the Scanner sends a File to the smb-Share)
  2. The Files are not shown in Nextcloud

The output of your Nextcloud log in Admin > Logging:

{"reqId":"JMAFQKR95iWfRHVKyonh","level":3,"time":"2024-05-17T06:42:14+00:00","remoteAddr":"80.131.147.148","user":"471AF5F4-0AD5-40D6-A2DB-BA9120CB7B74","app":"no app in context","method":"POST","url":"/ocs/v2.php/apps/files/api/v1/templates/create","message":"Ungültiger Pfad","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/124.0.0.0 Safari/537.36 Edg/124.0.0.0","version":"28.0.3.2","exception":{"Exception":"OCP\\Files\\GenericFileException","Message":"Ungültiger Pfad","Code":0,"Trace":[{"file":"/var/www/nextcloud/apps/files/lib/Controller/TemplateController.php","line":80,"function":"createFromTemplate","class":"OC\\Files\\Template\\TemplateManager","type":"->","args":["*** sensitive parameters replaced ***"]},{"file":"/var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php","line":230,"function":"create","class":"OCA\\Files\\Controller\\TemplateController","type":"->","args":["*** sensitive parameters replaced ***"]},{"file":"/var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php","line":137,"function":"executeController","class":"OC\\AppFramework\\Http\\Dispatcher","type":"->"},{"file":"/var/www/nextcloud/lib/private/AppFramework/App.php","line":184,"function":"dispatch","class":"OC\\AppFramework\\Http\\Dispatcher","type":"->"},{"file":"/var/www/nextcloud/lib/private/Route/Router.php","line":315,"function":"main","class":"OC\\AppFramework\\App","type":"::"},{"file":"/var/www/nextcloud/ocs/v1.php","line":65,"function":"match","class":"OC\\Route\\Router","type":"->"},{"file":"/var/www/nextcloud/ocs/v2.php","line":23,"args":["/var/www/nextcloud/ocs/v1.php"],"function":"require_once"}],"File":"/var/www/nextcloud/lib/private/Files/Template/TemplateManager.php","Line":159,"message":"Ungültiger Pfad","exception":[],"CustomMessage":"Ungültiger Pfad"},"id":"66470372b1209"}

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => 'oce8ygchhza0',
  'passwordsalt' => 'xxxxxx',
  'secret' => 'xxxxxx',
  'trusted_domains' =>
  array (
    0 => 'nextcloud',
    1 => 'xxxx',
    2 => 'xxxx',
    3 => 'xxxx',
  ),
  'datadirectory' => '/var/www/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '28.0.3.2',
  'overwrite.cli.url' => 'https://nextcloud',
  'dbname' => 'nextcloud_db',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextclouduser',
  'dbpassword' => 'xxxxx',
  'installed' => true,
  'ldapProviderFactory' => 'OCA\\User_LDAP\\LDAPProviderFactory',
  'trusted_proxies' =>
  array (
    0 => 'nextcloud',
    1 => '192.168.168.25',
    2 => 'xxxx',
    3 => 'xxxx',
    4 => '192.168.168.41',
    5 => '192.168.168.24',
    7 => 'xxxx',
 ),
  'maintenance' => false,
  'updater.secret' => 'xxxx'
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'loglevel' => 2,
  'theme' => '',
  'memories.exiftool' => '/var/www/nextcloud/apps/memories/bin-ext/exiftool-amd$'
  'memories.vod.path' => '/var/www/nextcloud/apps/memories/bin-ext/go-vod-amd64$'
  'memories.index.mode' => '2',
  'app_install_overwrite' =>
  array (
    0 => 'cfg_share_links',
  ),
'memcache.local' => '\OC\Memcache\APCu',

The output of your Apache/nginx/system log in /var/log/____:
The Access or Error?

That’s a normal and expected behavior and the topic is discussed on a regular base here. You need to execute the command files:scan ... to make Nextcloud aware of file changes.

1 Like

@MrB

Thanks to @j-ed this problem seems to be solved.

As I understand from your thread you haven’t been searching the forum yourself ahead of opening a new thread. Ya, I know that it’s a bit uncomfortable doing that at first but it would have saved you some time and trouble.
So please I kindly like to ask you to do that next time when you are experiencing problems.
thanks in advance

1 Like

okay sorry.

It works now perfectly. maybe the update fixed also some failures

1 Like