NextCloud Desktop and Web Client Refuses to Upload Certain Files

I really don’t know what’s going on, but I’ve been experiencing random 403 errors and refusal to upload / sync certain files at what seems to be totally random intervals.

I’ll give you the latest example:

Using the NextCloud desktop application for macOS (3.12.2) and NextCloud 28.0.3.

127 individual files, ranging between 20 - 30 MB (3.09GB in total). 4 of those 127 files just point-blank REFUSE to sync.

I tried to upload them using the web client and I get “Unknown Error” - but to be clear. I tried renaming them, same problem… I tried moving them to another folder… SAME problem.

The error that the desktop client displays is as follows:

Error transferring downloads/remote.php/dav/files/

CS240324032.DNG - server replied: Not Found

The small error which shows on the drop-down simply says: CS240324-RAW/CS240324032.DNG could not be synced due to an error. See the log for details.

(obviously file name is one of the 4 failed ones).

Inside the NextCloud Desktop application, it also says:


Server replied "403 Forbidden" to "PUT

Uploading into through the web interface simply says:

Estimating time left… then after a few seconds: Uploading "CS240324009.DNG" failed. Unknown error during upload.

In the Administration > Logging section, there are no entries at the time of these errors occurring.

There are no errors showing in web server logging either. Excuse the lack of technical diagnosis here… but it just seems to be specifically file-o-phobic… with very little explanation or information as to why it’s failing. It literally doesn’t make sense and it’s really annoying me.

Any ideas? I’m totally lost with this… it just doesn’t seem to have any logic what-so-ever.

Anyone going to provide an update / info?