Nextcloud Data Folder Permissions WSL (Windows Subsystem for Linux)

Dear community, I know windows is not the way to go but I would really, really :slight_smile: appreciate any help on the following matter:

I managed to successfully install nextcloud on windows using the linux subsystem / ubuntu 18.04. Everything runs smoothly, including setting up a letsencrypt certificate. The installer worked. But I do want to use a different drive for the data folder as the default would be (due to wsl) the c drive. And this causes massive issues.

The error was “please change permissions to 0770” to “cannot wrote .ocdata” or the famous “internal server error” message.

I tried to work with the typical command

sudo chown -R www-data:www-data /mnt/e/nextcloud

But this does not work, now I tried to mount the drive but this also did not work. However, I am a linux newbie and dont know how exactly to use the syntax.

I found some fstab setting in this forum but in WSL it seems not to work

E: /mnt/e drvfs rw,noatime,metadata,users,exec,umask=003,gid=33,uid=33

This leads to a drive e wich I cannot acces. Mount -l shows

E: on /mnt/e type drvfs (rw,nosuid,nodev,noatime,uid=33,gid=33,umask=3,metadata,case=off)

However, at least the nexcloud text file in the data folder is being created. Among lots of stuff I find for example “OCP\Files\NotPermittedException”,“Message”:“Could not create path” which refers (I guess) to the general issue, that nextcloud cannot write into that folder.

Does anyone managed to get a data folder on a different drive in WSL to work? If so how did you manage? Or does anyone have an idea how to properly mount the drive that nextcloud can use it?

I am using Nextcloud 16, Windows 10 (1903), Ubuntu 18.04, php7.2, apache2

Again, any help is highly appreciated.

1 Like

Exactly the same issue, did you figure out a solution?

1 Like

I was contemplating doing this (Nextcloud on WSL) but haven’t tried and my web searches came up with this which might solved your permissions issue - if it does please post what you did - thanks!


Hey. No solution found yet?

ìn general it would be better if you’d spin up a VM running linux and install NC there