Nextcloud & Collabora docker installation. Error: Collabora Online should use the same protocol as the server installation

I am in the process of installing Nextcloud and Collabora with Docker. I use the following docker-compose file to do the job:

https://github.com/nextcloud/docker/pull/630/files

I haven’t done any further configuration.

When I start the Collabora Integration app and fill in the collabora url [as: https://collabora_subdomain.domain.xx], I get the following error:

Collabora Online should use the same protocol as the server installation

When I try to open a document I get:

Failed to load Collabora Online - please try again later

Where could the problem lay?

I had the same problem with a nextcloud instance in a docker container behind a reverse proxy which does the transport encryption. Try connecting directly to the container without connecting to the proxy and check the mark beside “accept self-signed certificats”.

Hi @kromsam, I’ll post this response in both places.

Here is a snippet from my /app/config/config.php, my assumption is you need to add the lines for overwritehost and overwriteprotocol. This is necessary if you wish to use the passwords app as well. Be sure to use your actual hostname for your nextcloud where I have used cloud.example.com below. If setup properly there should be no reason to manually go around your letsencrpt certs.

$CONFIG = array (
  'htaccess.RewriteBase' => '/',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'trusted_proxies' => 
  array (
    0 => '172.30.0.3',
  ),
  'overwritehost' => 'cloud.example.com',
  'overwriteprotocol' => 'https',
  'apps_paths' => 
  array (
...

All the best,
Aaron

Hey I have the same problem. I have installed it with the Compose file below.
If I open the office.domain.tdl, the Website from Collabora give me a request “Ok”.
But I can’t bind it in Nextcloud.

I have seen on my nextcloud.domain.tld that I get an error -->

{status: 0,…} message: "cURL error 6: Could not resolve host: office.domain.tld (see http://curl.haxx.se/libcurl/c/libcurl-errors.html)" status: 0

What can I do, to fix that?

I started again using another repo: https://github.com/ReinerNippes/nextcloud_on_docker

This worked out for me

@kromsam since sunday onlyoffice is also possible to setup. :wink:

@Reiner_Nippes Cool work :ok_hand:

@Reiner_Nippes Last but not least it will be the “cream of” if you integrate fulltextsearch with elasticsearch and tesseract (works fine since last update to 1.3.x)

@ralfi to you have a link to a very good howto?

Not really because depends on many settings …

I will send you a message tomorrow. IMHO the best to use is a single modified elasticsearch docker container. In my configuraion, elasticsearch runs on the host who picked up the docker images for nextcloud and lool. It works but with a separated docker image should be better because you have a clear defined and simply configuration.

@Reiner_Nippes


https://www.elastic.co/guide/en/elasticsearch/reference/6.7/docker.html

apt install apt-transport-https ca-certificates wget gnupg openjdk-8-jre

wget -qO - https://artifacts.elastic.co/GPG-KEY-elasticsearch | apt-key add -
echo “deb https://artifacts.elastic.co/packages/6.x/apt stable main” | tee -a /etc/apt/sources.list.d/elastic-6.x.list

apt update && apt install elasticsearch

Install from Nextcloud Store (v 1.3x)

Fulltextsearch
Fulltextsearch - Elasticsearch Platform
Fulltextsearch - Files
Fulltextsearch - Tesseract OCR

Configure apps ( see screenshot )

OCR PICS -> TEXT inside PPICs
apt install tesseract-ocr tesseract-ocr-deu tesseract-ocr-eng

OCR PDF (PDF Fulltextsearch Plugin)
/usr/share/elasticsearch/bin/elasticsearch-plugin install ingest-attachment

configuration: /etc/elasticsearch/elasticsearch.yml
network.host: “IP-Adress elasticsearch host”

systemctl restart elasticsearch.service

Check: http://“IP-Adress elasticsearch host”:9200
OR
curl -XGET ‘“IP-Adress elasticsearch host”:9200/?pretty’

I added a branch elasticsearch for development and testing.
Right now only an elasticsearch container is created.
You have to manually install and configure the nextcloud apps.

The server address would be:

@ralfi How to test if tesseract is working correct?

Mmmh,

first of all… Does your nc resolve “elasticsearch_tesseract” to a ip address and can connect to port 9200? Where is the elasticsearch container or package located?

Does your fulltextsearch work including PDF indexing? In your nc shell as user www-data you can check the core app this with “php occ fulltextsearch:test”.

For testing purpose of tesseract i modify a default nc picture with two unique strings (for testing utf-8 compatibility i use “Eichhörnchen”) and update the index. Then you can find this picture if you search for this string in the nextcloud searchbox.

Be aware: Creating first index can work a long time if you have a lot of files. For me the first index creating time was about five hours (12000 Pics, 900 Docs, PDF…) but - i really dont know how this works - updating index and compare is finished after around 2 minutes.

fulltext search was working. I could find text inside a pdf. everything fine at this point.
what’s mssing (and will be soon added) is the configuration of nextcloud (app install, first index, live index, complete the config page in nc, etc. pp.)

it’s the container name used by the internal docker dns server.

ok. i’ll try.

when the playbook runs the nextcloud normally is empty. :wink:

btw: we should start a new thread. right now it’s no longer a collabora thing we discus here.

Of course, i forget that the playbook is for install. I do not use anything from your repo at this time but i will try a deeper look asap … Thanks for this cool work!

@ralfi [quote=“ralfi, post:15, topic:51582”]
i will try a deeper look asap
[/quote]
You may try now. I added the automatic configuration.

But don’t forget a ‘git checkout elasticsearch‘ before you run the playbook.

1 Like