Nextcloud & Collabora CODE docker compose almost everything is working - except it isn't

Hello there

I’ve been setting up collabora code on my existing nextcloud instance and was quite positively surprised that everything just worked (despite reading a lot of mixed expreriences). I can create, edit and share files without any problems. :tada:

[11:42:48] [~] ❱❱❱ curl https://office.mydomain.tld

Until i tried to access the admin console of collabora…I tried to access it via: https://office.mydomain.tld/browser/dist/admin/admin.html → a login prompt appears and I can’t log in using my defined credentials. Or any other credentials.
I’ve set the “username” and “password” in the environment variables in my docker-compose file as well as the commonly mentioned ssl extra_params (extra_params appear to be working).

In addition, I then tried to upload custom fonts via the Nextcloud Office Administration Settings and add the custom font json via extra_params as well. This also doesn’t work.

Here is my docker-compose config for collabora:

    image: collabora/code
    hostname: nc-collabora
    privileged: true
    restart: unless-stopped
      - TZ=Europe/Zurich
      - dictionaries=de_DE
      - VIRTUAL_HOST=office.mydomain.tld
      - aliasgroup1=https://cloud.mydomain.tld
      - server_name=office.mydomain.tld
      - username="${COLLABORA_USERNAME}"
      - password="${COLLABORA_PASSWORD}"
      - "extra_params=--o:ssl.enable=false --o:ssl.termination=true --o:remote_font_config.url=https://cloud.mydomain.tld/apps/richdocuments/settings/fonts.json"
      - proxy
      - nextcloud

After some more digging I found that the coolwsd command inside of the docker container doesn’t work as well:

cool@nc-collabora:/$ coolwsd
Failed to initialize COOLWSD: Access to file denied: /usr/bin/jails
wsd-00081-00081 2024-02-27 11:51:11.752447 +0100 [ coolwsd ] INF  Initializing wsd. Local time: Tue 2024-02-27 11:51:11 +0100. Log level is [8]| common/Log.cpp:597
wsd-00081-00081 2024-02-27 11:51:11.752463 +0100 [ coolwsd ] INF  Setting log-level to [trace] and delaying setting to [warning] until after WSD initialization.| wsd/COOLWSD.cpp:2424
wsd-00081-00081 2024-02-27 11:51:11.752469 +0100 [ coolwsd ] INF  Initializing coolwsd server []. Experimental features are enabled.| wsd/COOLWSD.cpp:2435
wsd-00081-00081 2024-02-27 11:51:11.752478 +0100 [ coolwsd ] DBG  New SocketPoll [UnitWSD] owned by 0x7f07350da880| net/Socket.cpp:199
wsd-00081-00081 2024-02-27 11:51:11.752526 +0100 [ coolwsd ] INF  Anonymization of user-data is configurable.| wsd/COOLWSD.cpp:2504
wsd-00081-00081 2024-02-27 11:51:11.752534 +0100 [ coolwsd ] INF  Anonymization of user-data is disabled.| wsd/COOLWSD.cpp:2551
wsd-00081-00081 2024-02-27 11:51:11.752548 +0100 [ coolwsd ] INF  SSL support: SSL is enabled.| wsd/COOLWSD.cpp:2601
wsd-00081-00081 2024-02-27 11:51:11.752550 +0100 [ coolwsd ] INF  SSL support: termination is disabled.| wsd/COOLWSD.cpp:2602
wsd-00081-00081 2024-02-27 11:51:11.752554 +0100 [ coolwsd ] DBG  Setting envar PDFIMPORT_RESOLUTION_DPI=96 per config per_document.pdf_resolution_dpi| wsd/COOLWSD.cpp:2628
wsd-00081-00081 2024-02-27 11:51:11.752571 +0100 [ coolwsd ] INF  Creating childroot: /usr/bin/jails/81-b2a527db/| wsd/COOLWSD.cpp:2668
wsd-00081-00081 2024-02-27 11:51:11.752950 +0100 [ coolwsd ] INF  Cleaning up childroot directory [/usr/bin/jails/].| common/JailUtil.cpp:200
wsd-00081-00081 2024-02-27 11:51:11.752955 +0100 [ coolwsd ] TRC  Directory [/usr/bin/jails/] is not a jail directory or doesn't exist.| common/JailUtil.cpp:205
wsd-00081-00081 2024-02-27 11:51:11.752956 +0100 [ coolwsd ] INF  Cleaning up childroot directory [/usr/bin/jails/81-b2a527db/].| common/JailUtil.cpp:200
wsd-00081-00081 2024-02-27 11:51:11.752958 +0100 [ coolwsd ] TRC  Directory [/usr/bin/jails/81-b2a527db/] is not a jail directory or doesn't exist.| common/JailUtil.cpp:205
wsd-00081-00081 2024-02-27 11:51:11.752960 +0100 [ coolwsd ] INF  Creating jail path (if missing): /usr/bin/jails/81-b2a527db//tmp/incoming| common/JailUtil.cpp:279
wsd-00081-00081 2024-02-27 11:51:11.753028 +0100 [ coolwsd ] FTL  Failed to initialize COOLWSD: Access to file denied: /usr/bin/jails| wsd/COOLWSD.hpp:534
Access to file denied: /usr/bin/jails

And on top of that, if I change settings in the Administration Settings of Nextcloud Office, i can’t disable the checkboxes again after enabling them:

The Allow list for WPOI requests just fails silently.

I’ve spent the last couple of days trying a lot of different things and probably read every post on all forums known to man and wasn’t able to figure this one out.

I’d be happy to provide additional logs if it helps.

System infos:
OS: Debian 5.10.205-2
Nextcloud: 28.0.2 → nextcloud:latest docker image
Collabora: collabora/code docker image

Thanks in advance :slight_smile:

hi @scorewinner welcome to the communitiy :handshake:

regarding issues specific to dedicated CODE you better ask Collabora forum.

regarding checkboxes in Nextcloud Office admin section - I can repro the issue for “restrict usage/edit to specific groups” but I can successfully edit the group list… as long the list is empty it seems to cause no harm… I can successfully enable/disable other checkboxes e.g. “Use Office Onpen XML…”

I reported an issue at Github: [Bug]: Unable to uncheck 'restrict usage/edit to specific groups' in Nextcloud Admin Settings · Issue #3506 · nextcloud/richdocuments · GitHub

In general please don’t mix different issues in one thread - better ask one question per issue.

Hi @wwe
Thanks for the quick response, appreciate it.

I will go and take a look if I can get some infos in the Collabora Forum :+1:

Thanks for reporting the issue, can confirm that it’s only the two checkboxes you mentioned :bowing_man:

as a result of trying to fix all those burning piles I wasn’t sure what issue belongs where and just thought i’d compile everything into one thread, will try to better myself :smile: