Nextcloud clients wont connect But I can login via Web

I am new to Nextcloud; I apologize if this question has been asked and answered. I did search the forums and online in general for an answer. However, I cannot find a solution to my problem.

I’ve installed Nextcloud and it is self hosted on an Apache VPS server. I am able to access Nextcloud via browser, but none of the clients will connect. I tried android, windows, macos, and ios clients.

When I try to login via client, it takes me to a browser to login, and I login successfully. I return to client and I get “Failed to connect to secure server address myserver.com. How do you wish to proceed?” I did try the other options, one is “retry unencrypted over HTTP,” and this also failed.

When visiting the Nextcloud log, there is no information. Under “Devices & Sessions” it shows the desktop client logged into my account.

Any suggestions or advice? What additional information should I include to help decipher the issue?

Thanks, in advance, for your time.

Here you have a troubleshooting guide:
https://docs.nextcloud.com/desktop/3.7/troubleshooting.html

It seems to indicate some problem with the SSL connection, a way to check the server’s settings from outside is SSL Server Test (Powered by Qualys SSL Labs)
And if there everything is ok, from the troubleshooting the most interesting would be the client logs that it gives more details why it failed.

Thank you for your response. Yes, during my search for a resolution, a few weeks ago, I did come across running the SSL server test. At that time everything passed. I am running it again and the score is an A+.

Reviewing the link you suggested, described a possible WebDAV API issue and to check if I can connect via browser http://yoursite/nextcloud/remote.php/dav

In doing so the browser responded “This is the WebDAV interface. It can only be accessed by WebDAV clients such as the Nextcloud desktop sync client.”

I also entered the same into the Nextcloud desktop client for MacOS and the client responded “failed to connect to http://yoursite/nextcloud/remote.php/dav: host requires authentication.” It did not give me the option to authenticate. However, it seems like it can be reached and functioning correctly?

Nextcoud MacOS Client Log
2023-03-05 12:08:34:420 [ info nextcloud.gui.application /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/application.cpp:594 ]: ################## “Nextcloud” locale: “en_US” ui_lang: QVariant(QString, “en_US”) version: “3.7.3git (build 13809)” os: “macOS 13.2”
2023-03-05 12:08:34:420 [ info nextcloud.gui.application /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/application.cpp:599 ]: Arguments: (“/Applications/Nextcloud.app/Contents/MacOS/Nextcloud”)
2023-03-05 12:08:36:855 [ info nextcloud.gui.folder.manager /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/folderman.cpp:951 ]: Etag poll timer timeout
2023-03-05 12:08:36:855 [ info nextcloud.gui.folder.manager /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/folderman.cpp:955 ]: Folders to sync: 0
2023-03-05 12:08:36:855 [ info nextcloud.gui.folder.manager /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/folderman.cpp:965 ]: Number of folders that don’t use push notifications: 0
2023-03-05 12:09:06:854 [ info nextcloud.gui.folder.manager /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/folderman.cpp:951 ]: Etag poll timer timeout
2023-03-05 12:09:06:854 [ info nextcloud.gui.folder.manager /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/folderman.cpp:955 ]: Folders to sync: 0
2023-03-05 12:09:06:854 [ info nextcloud.gui.folder.manager /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/folderman.cpp:965 ]: Number of folders that don’t use push notifications: 0
2023-03-05 12:09:26:926 [ info nextcloud.gui.socketapi /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/socketapi/socketapi.cpp:319 ]: New connection QLocalSocket(0x6000036e7ae0)
2023-03-05 12:09:26:926 [ info nextcloud.gui.socketapi /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/socketapi/socketapi.cpp:369 ]: Received SocketAPI message ← “GET_STRINGS:” from QLocalSocket(0x6000036e7ae0)
2023-03-05 12:09:26:926 [ debug nextcloud.gui.socketapi /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/socketapi/socketapi.cpp:212 ] [ OCC::SocketListener::sendMessage ]: Sending SocketAPI message → “GET_STRINGS:BEGIN” to QLocalSocket(0x6000036e7ae0)
2023-03-05 12:09:26:926 [ debug nextcloud.gui.socketapi /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/socketapi/socketapi.cpp:212 ] [ OCC::SocketListener::sendMessage ]: Sending SocketAPI message → “STRING:SHARE_MENU_TITLE:Share options” to QLocalSocket(0x6000036e7ae0)
2023-03-05 12:09:26:926 [ debug nextcloud.gui.socketapi /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/socketapi/socketapi.cpp:212 ] [ OCC::SocketListener::sendMessage ]: Sending SocketAPI message → “STRING:FILE_ACTIVITY_MENU_TITLE:Activity” to QLocalSocket(0x6000036e7ae0)
2023-03-05 12:09:26:926 [ debug nextcloud.gui.socketapi /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/socketapi/socketapi.cpp:212 ] [ OCC::SocketListener::sendMessage ]: Sending SocketAPI message → “STRING:CONTEXT_MENU_TITLE:Nextcloud” to QLocalSocket(0x6000036e7ae0)
2023-03-05 12:09:26:926 [ debug nextcloud.gui.socketapi /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/socketapi/socketapi.cpp:212 ] [ OCC::SocketListener::sendMessage ]: Sending SocketAPI message → “STRING:COPY_PRIVATE_LINK_MENU_TITLE:Copy private link to clipboard” to QLocalSocket(0x6000036e7ae0)
2023-03-05 12:09:26:926 [ debug nextcloud.gui.socketapi /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/socketapi/socketapi.cpp:212 ] [ OCC::SocketListener::sendMessage ]: Sending SocketAPI message → “STRING:EMAIL_PRIVATE_LINK_MENU_TITLE:Send private link by email …” to QLocalSocket(0x6000036e7ae0)
2023-03-05 12:09:26:926 [ debug nextcloud.gui.socketapi /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/socketapi/socketapi.cpp:212 ] [ OCC::SocketListener::sendMessage ]: Sending SocketAPI message → “STRING:CONTEXT_MENU_ICON:Nextcloud-macOS” to QLocalSocket(0x6000036e7ae0)
2023-03-05 12:09:26:927 [ debug nextcloud.gui.socketapi /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/socketapi/socketapi.cpp:212 ] [ OCC::SocketListener::sendMessage ]: Sending SocketAPI message → “GET_STRINGS:END” to QLocalSocket(0x6000036e7ae0)
2023-03-05 12:09:36:854 [ info nextcloud.gui.folder.manager /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/folderman.cpp:951 ]: Etag poll timer timeout
2023-03-05 12:09:36:854 [ info nextcloud.gui.folder.manager /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/folderman.cpp:955 ]: Folders to sync: 0
2023-03-05 12:09:36:854 [ info nextcloud.gui.folder.manager /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-13809/src/gui/folderman.cpp:965 ]: Number of folders that don’t use push notifications: 0

If you use the Nextcloud client, just give the main URL (http://yoursite/nextcloud). The client will then find itself the right path within Nextcloud. For an external webdav client, you need a full URL that also needs your user’s name. You can get this link when you are in the file app and on the left buttom corner, there are some settings where you can copy the full webdav path.
It would be interesting to see if the usual webdav connection works, just keep in mind that the default windows and mac clients from the system are not the best (either do some of their own stuff or are a bit buggy or tricky to set up). WinSCP or Cyberduck or some other software might help you.

I did try Cyberduck to login via full URL and I have the same result. I will try your suggestion.

I did get my full path, it’s still asking for authentication, but not giving me a dialog box to enter username and password. Do I pass my credentials via URL? What is does that look like?

Thank you for your help. I went thumbing through a few settings and I found PHP-FPM was not enabled for the domain.

I enabled and it is now connecting via the native Nextcloud client for MacOS.

Much appreciated!

But how could you login via web?

Well, in the end it’s good that you fixed it.