Nextcloud -client refuses to start on boot

Nextcloud version: 15.0.7
Operating system and version: Ubuntu 18.04
Apache or nginx version: Apache 2
PHP version: 7.2

The issue you are facing:

I have the Nextcloud client set up on my computer (also Ubuntu 18.04) and it never starts on boot.

Is this the first time you’ve seen this error?: Always, since I started using Nextcloud

Steps to replicate it:

  1. Click ‘Launch on System Startup’ in general settings.
  2. Restart
  3. Have to manually start the client

I should point out that I’ve used the snap version, then removed it and install with apt, but I have the same problem

3 Likes

I also hit f12 to view the logs, and there was nothing there. I double-checked that the program was in my startup applications, and it is. I even tried to create a @reboot cron job for it. Nothing seems to get it going on boot.

This is frustrating because I often make changes on my desktop and my phone, and if the client doesn’t auto-start, then I’m more likely to have conflicts.

Same problem here.

Did you find a solution?

Edit:
My workaround was adding it to autostart directly by GUI. But I assume this is not the expected behavior.

I’m using Linux Mint 19.2 on Kernel 5.0.

It worked for me after correcting a wrong path to the nextcloud client in the existing file ~/.config/autostart/Nextcloud.desktop

For me it had to be /usr/bin/nextcloud instead of some path pointing to temporary folder.

2 Likes

It worked for me as well!
exec Path was pointing to something like
Exec=/tmp/.something…/usr/bin/nextcloud
After setting it to
Exec=/usr/bin/nextcloud
it worked.

1 Like

This solution does not work for me in Ubuntu 20.04, the path was already correct.

the path /usr/bin/nextcloud is not always the correct one, it depends on how you installed the client. if it was installed with flatpak, try this

Exec=flatpak run com.nextcloud.desktopclient.nextcloud --background

Source: How to start Flatpak applications on boot up