Nextcloud client not to be launched since update


I found out this morning I had no more access to Nextcloud client… I’im using Linux Mint. Here’s what I’ve got : in the console :

$ /usr/bin/flatpak run --branch=stable --arch=x86_64 --command=nextcloud --file-forwarding com.nextcloud.desktopclient.nextcloud @@u %u @@

Qt: Session management error: Could not open network socket
nextcloud.gui.application: Migrating old config from “/home/kristen/.var/app/com.nextcloud.desktopclient.nextcloud/data/Nextcloud” to “/home/kristen/.var/app/com.nextcloud.desktopclient.nextcloud/config/Nextcloud”
nextcloud.gui.application: Failed to move the old config directory to its new location ( “/home/kristen/.var/app/com.nextcloud.desktopclient.nextcloud/data/Nextcloud” to “/home/kristen/.var/app/com.nextcloud.desktopclient.nextcloud/config/Nextcloud” )
nextcloud.gui.application: Will move the individual files (“Nextcloud2_sync.log”)
nextcloud.gui.application: Fallback move of “Nextcloud2_sync.log” also failed
Unrecognized option ‘%u’
Try ‘nextcloud --help’ for more information

Thanks for your help


on Mint Mate I’ve got the same issue, not starting. Tried reinstall but no result.
On Mint Cinnamon it’s still working but the sys tray icon is broken.

Hope there’ll be a fix soon.

1 Like

Hopefully… I’m on Mate too. Thanks for your answer

Next time please provide version information to get support. We cannot guess your client version.

“latest” = 3.11.0 via flatpak

It’s already on github now too (both versions).

The issue about the flatpak not starting would probably be better placed here, since as far as I can tell this issue is specific to the flatpak, meaning that the maintainers of the flatpak need to fix it.

1 Like

Hi, I did a downgrade of the flatpak:

flatpak list
flatpak remote-info --log flathub com.nextcloud.desktopclient.nextcloud
sudo flatpak update --commit=08e53a14920ec5b626ff13a7c65f41185241cbcdd5a3e5dd5646a27393433236 com.nextcloud.desktopclient.nextcloud

Thanks a million, R4u5ch ! It worked well for me. It looks likes it is a path prob. :

Updating… ████████████████████ 100%  2,7 MB/s

Note that '/var/lib/flatpak/exports/share' is not in the search path set by the XDG_DATA_HOME and XDG_DATA_DIRS environment variables, so applications may not be able to find it until you set them. The directories currently searched are:
- /root/.local/share