Nextcloud client for Android not working at all

I just have installed Nextcloud on my webspace, which is hosted by an ISP. After having solved som problems, I can sync to the calendar with Thunderbird, which is running on a Lubuntu PC and also on a Windows 7 PC. Unfortunately I cannot sync tasks in Thunderbird (which I have asked for a solution in another thread here in this forum).
It is of great importance for me, that I get access to Nextcloud calendar, tasks and some files via Smartphone. I have an old Samsung galaxy S2 with android 4.01 on which I have installed Nextcloud client. While installing, it checked the connection to the Nextcloud server and it seemd, that it could connect. But after this, I got only the rotating wheel, indicating that Nextcloud client “is trying something”, but without effort. There is no error message oder something else.
In the menu “settings” I saw, that for syncing with calendar, it would be necessary, to install DAVdroid also. I did and entered all the credentials again. But also DAVdroid was “loading” and never came to success.

Then I remembered, that I had aCal on my phone. It seems, that aCal and aCalTasks etc. are not in active development anymore, as I saw the latest entries in github dated on 2013. In spite of this I did give it a chance: et voila! I could manage and sync my calendar and also my tasks.
This result let me think, that the problem is in Nextcloud Anroid client and not within my installations.

The GUI of aCal and aCalTasks is not really userfriendly. Further it shows no categories for the tasks and also it does not show a task with several sub tasks. Everything shows up on the same level and so it is hard, to set priorities and keep overview.
I hope, that Nextcloud Android client will come with a far more better GUI.

So please, what can I do, to get Nextcloud for Android up and running?

@Andy @tobiasKaminsky support for 4.x?

Is it an i9100? Thinking laterally, you can actually update your phone to Android 7.1 (Nougat) by installing LineageOS 14.1 (successor to Cyanogenmod).

That would solve your compatibility problems (and your many many unpatched security issues!)

The client itself support Android 4.0.x at this moment, not sure if 4.01 means 4.0.1 (then yes) but I think so since you could install the client. If you only see the progress wheel than it might be another issue maybe also related to the server so it would be best to open an issue on Github:

My Galaxy S2 is a GT-I9100, ARM Cortex A9 2-cores, Android-Version is 4.0.3.
I don’t think, that Nextcloud client cannot work with it, because I have aCal and aCalTasks working nearly flawless with my Nextcloud-Server. Further I can sync calendars with my Thunderbird clients on Lubuntu and on Windows.
Because of this, I think, that my Nextcloud-Serverside is OK and I suppose, that Android Nextcloud client causes the trouble and I am hoping, to get some ideas here…

Of course I would like to switch to LineageOS 14.1. But I neither have the time nor the knowledge, to do this change AND have all my apps running again after this step. And til now I have not found a service offer, to do this for me.

Fair enough, if you’re not confident I completely understand you don’t want to brick your phone. I just thought that if you can set up and run a cloud server, changing the OS on your phone shouldn’t be too much of a problem!

I’m self taught. I read a few forums, and just followed a guide I found online. It’s not that scary.

I’m actually still running Cyanogenmod 11 and ownCloud 9.1. Once I have the time, I’ll be upgrading to LineageOS 14.1 and Nextcloud 12. I hate that I’m still running Android 4.4, I can’t imagine being stuck on 4.0!

I wonder about, that I don’t get an answer to my main question, concerning Android NC client not working on my Phone. Instead of, I get advise, to upgrade my phone, allthough other CalDAV Apps are working well. And now, it seems that we should discuss my abilities, wether I have the abilities to upgrade on my phone.
I cannot believe that this is the „art of normal discussion” in this forum! :slight_smile:

Could we please go back to answer my originally posted question???

Sorry! I didn’t mean to sound like I was attacking!

I could be wrong, but it sounds like your server setup doesn’t support older Android OSes. If an app uses OS system calls for it’s functions, the app is limited to what the OS can provide. If the app handles the functions themselves then they’re not limited to what the OS can do.

I’m guessing aCal handles the newer protocols and functions itself, so it can still talk to your server. The other non-functioning apps are trying to call on (non-existent) OS functions in response to your server’s demands.

I’d recommend trying the “old” settings provided by the Mozilla SSL Configuration Generator. That will even allow IE6 to connect. If the apps work with “old” settings, you know it’s a server configuration issue. Don’t leave the server that way, of course! If that gets the app working, then you need to figure out setting that are a good balance between security and support for old OSes.

To better explain, here’s a screenshot of my SSL Labs results:

Because I have a phone running Android 4.4, I configured my server to work with that, and nothing older. You can see how your server is configured by entering it here. It will tell you if your server can actually talk to Android 4.0 or not. I’m guessing that’s your problem.

If that doesn’t help, I guess it’s back to trying LineageOS :wink:

Hi Steve!
Thank you for that helpfull link. I never have tested my server via the SSLab. My server is hosted by a service provider, the server product is called „managed server”. I only know the general function of a server and don’t know in detail, what I am doing there.
On my webspace, I have setup four Joomla websites. Each is separated from the other via quotas. By intensive help via the forum of that provider, I have one superior htaccess for all of these websites, which filters all sorts of usual hacker attacks. This htaccess is in the top directory. The websites lay in sub-directories with their own htaccess. The rules of the main htaccess will be inherited to the htaccess in the sub-directories. This setting works well and stable since 6 years ago!
The admin access to my Joomla webistes is restricted to a https-connection while the frontend is normal http. I have tested these websites via SSLab, as you have recommended and they fail!
The server is found and connected OK. It is ranked as “T”. Beneath this first table line I find a hexadecimal adress and under it, SSLab tells me “Unable to connect to the server”.
Beneath both table lines, SSLab tells me: Warning: Inconsistent server configuration.

I get the same result by testing my nextcloud installation. I cannot find something like you show in your screenshot, and I do not know, how to initiate a handshake Simulation on the SSLab website.
My Nextcloud installation is totally separated from the websites in a separate directory and operates under the influence of only the htaccess, which comes with nextcloud itself. I did not modify it in any way. So we have a clean NC installation without any hooks and tricks.

I have no idea, why SSLab tells me, that the server would have an inconsistent configuration! And this warning is the same on all of my websites and on NC installation also.

Perhaps now you see, that I do not have by far the knowledge, you have assumed, I would have! :slight_smile:

Kind regards

PS: My way to install NC on that server has been:
Extract the ZIP-file of NC on my PC and upload all this stuff via ftp in a separate directory. Further I have created a MySQL database in the management websurface for my managed hosting and created a subdomain, which pointed to the NC directory. Then I started the NC setup process and told NC to connect to the MYSQL database. The username and the password consist of 20 typos. By this description, you know, in which status my NC installation is.

Feel free to test against my demo servers:

9, 10, 11, 12 all available. Perhaps that’ll help.

I got that when I used a self-signed certificate. If that’s from your certificate (that you created), it should be ok. But if that’s what your provider has given you, it’s pretty bad! Globally recognised certificates (from an accredited Certificate Authority) are free nowadays.

It should be a part of the standard tests, I didn’t request anything special. I’m guessing those handshake tests weren’t performed since you had webserver configuration errors.

Do you have access to your webserver configuration files? Do you know if your provider uses Apache or Nginx? (I’m only familiar with Apache, and pretty much only on FreeBSD).

Going by everything you’ve said, this isn’t a NextCloud problem, it’s an Apache/Nginx problem. Once you’ve got your webserver fixed, then you can worry about any additional NextCloud issues :slight_smile:

Here’s a weird thing to check - when connecting to your NextCloud (or other sites), are you connecting via “http” or “https”? See what happens when you try both. It might be that you have no certificate configured at all (this might be a factor in your “T” trust issues). I noticed a while ago that some websites gave “untrusted” errors when connecting via https, but connected just fine over http. They simply have no SSL configured at all in their webservers.

My next move would be to see what kind of webserver I had, and whether or not I had access to it’s configuration files. If you can access the config files I’d check to see if SSL is configured at all, and how my “vhosts” (virtual hosts) are configured. You might have to use a panel or portal of some kind to access your server configuration, and see if (or how) SSL is configured. If SSL is not configured at all, that will be your problem!

Now, it’s 2:48am here in Australia, so I’m off to bed! Good luck!

You are right: I have https with selfs signed certificate.
I have checked my Smartphone again and I remembered my safety settings in AF-Wall and in XPrivacy. Allthough everything in XPrivacy was accepted, which was required from Nextcloud client, I have experimentally allowed everything for Nextcloud. And now NC client could connect without any problems to the NC server!
Problem solved!
But I wanted to have my calendar and my tasks syncronized! Now I understand, that NC client wants to have DAVdroid installed, in order to make a „bridge” between calendar and task plugin of NC server and appropriate Android apps like any calendar app on the phone.
I don’t feel comfortable with such a solution and therefore I want to have aCal running which comes with an integrated calendar and a combined aCalTasks app. To make sure, that aCal has the same conditions as the NC client, I have XPrivacy allowed everything for aCal. When I tested the bidirectional syncing, I found, that sometimes for more than 1 hour no sync is done inspite I had changed some entries in the aCal calendar and also in NC via the web interface.
It seems that there is no fixed time between the consecutive syncing processes and syncing may take up to more than 1 hour. This is far too much! And I don’t see settings, to reduce the sync time.
Further I found, that in Android there is a central sync setting available: Settings -> Accounts & Sync There I checked, wether all my DAV apps are listed and set up for syncing. But on no account I could set the time between two sync processes.
In the end I can resume:
It seems, that my server is OK, but could be improved somehow.
It seems, that my old smartphone and Android 4.0.3 is OK for NC client.
I want to shorten the time between two sync processes (with aCal).
I want to manage tasks in Thunderbird. No task shows up there til now! (But this is my question in separate thread in this forum.
Kind regards and thanks for your hints and advice!

PS: My Webspace is based on a LAMP-Server, latest PHP active. Just now I have setup the Cron job with NC cron.php to every 10 minutes. I wonder wether now syncing will perform, as I want.

I installed DAVdroid, only to realise it doesn’t work with self signed certificates. I don’t mean to sound like an advertisement, but is it at all possible to use Let’s Encrypt? Unless there are very specific reasons, CA certs are your best way to avoid problems. If you can’t use a CA cert, there are alternatives to DAVdroid.

I used CalDav Sync Adapter, and it worked brilliantly with my self signed certs. Now I use “Easy Dav for ownCloud”, but I haven’t tried using it on NextCloud (I’m stuck on ownCloud until I can replace my Mozilla sync server!)

Hmm, yeah. I still haven’t solved that. I’m still stuck on ownCloud (for now), but have the same issue. Tasks never worked for me, so they’re (ironically) on my to-do list. I’ll let you know when I solve it! Until then, I’m using a Word doc sync’d with ownCloud ;-)[quote=“Clemens, post:12, topic:13006”]
My Webspace is based on a LAMP-Server

I’m using a “BAMP-Server”, it’s just like yours but uses BSD instead of linux, and is hosted in my spare bedroom! I’m using PHP 5.6 instead of 7.x (because Roundcube wasn’t compatible with 7 when I installed it).

Unlike a lot of people online, I don’t think there’s anything inherently wrong with self signed certificates, however fewer and fewer apps accommodate them. It took me several attempts to find apps that worked well. Keep trying! There’s more than one way to skin a cat (though not many more ways, just a few, and fewer as time moves on - use Let’s Encrypt or some other free CA if possible!)

I’m glad I was able able to help, even if my advice is clumsy and indirect :wink:

(Now it’s 3:34am so I’m off to bed again :stuck_out_tongue_winking_eye:)

I found out some new things:
aCalendar in its original free version from F-Droid is the only CalDAV-App which comes with its own calendar and is working with my old android 4.0.3. But it seems to be buggy. Especially when I want to delete some tasks oder some calendar events, it can happen, that nothing is deleted on the server. Or it is deleted on the server but the entries are still shown in the app! This is unreliable.
Few other CalDAV apps could solve my problem, but they require android higher 4.3

And DAVdroid does not sync with self signed https servers, so that it is not useable here.

Because of my high confidential data in the calendar, I cannot afford to use google calendar or any app, which works together with google.

The only solution for me is now, to flash my smartphone and change to LineageOS 14.1 (without Google) This will raise the Android level up to the actual release 7.1 and I would be free, to use any actual app, which will keep my privacy.

Now I am struggling with flashing my smartphone. It is rooted, CWM is installed and SuperSU also. But the flash software “Heimdall” cannot connect to my smartphone via USB. Very time consuming and frustrating…

I just wanted to keep you informed abaout my latest efforts…

Sorry to resurrect this thread… I have just found this thread with a search engine and want to add some corrections about DAVdroid (because the content can be found easily with DAVdroid keywords).

I installed DAVdroid, only to realise it doesn’t work with self signed certificates. I don’t mean to sound like an advertisement, but is it at all possible to use Let’s Encrypt? Unless there are very specific reasons, CA certs are your best way to avoid problems. If you can’t use a CA cert, there are alternatives to DAVdroid.

DAVdroid works with self-signed certificates since version 0.9 (released ~ 3 years ago). Support has been improved in DAVdroid 1.3, when we have released cert4android (an open library for exactly that purpose). Many people are using it that way without problems.

I used CalDav Sync Adapter4, and it worked brilliantly with my self signed certs. Now I use “Easy Dav for ownCloud”, but I haven’t tried using it on NextCloud (I’m stuck on ownCloud until I can replace my Mozilla sync server!)

“EasyDAV for Owncloud” is just a DAVdroid clone by someone else. It has exactly the same core as DAVdroid, but is not updated anymore.

1 Like

Cool, but it’s no longer really an issue. Back when I had trouble getting things to work with self-signed certs, there wasn’t really free CA option (without needing to jump through lots of hoops). Let’s Encrypt cured that. With very few exceptions, there’s a free CA option available for the vast majority of situations.

Like most people, I’m a creature of habit. Davdroid didn’t work for me when I needed it, and Caldav Sync Adapter kept intermittently failing for various versions of ownCloud, but EasyDAV worked flawlessly in both situations, so I continued using it. I saw that the Nextcloud app was pushing Davdroid, but my phone was still running EasyDav since before upgrading from ownCloud to Nextcloud, and why change what’s working?

Others have previously told me that EasyDav was a clone of Davdroid, but it was a clone that worked when the original didn’t. Once I upgraded my phone from Cyanogenmod to LineageOS, I needed to reinstall everything, and since I was now using CA cert, I switched to Davdroid :slight_smile:

Don’t stress, I’m not recommending EasyDav or anything, I use Davdroid daily myself (though I wasn’t aware it now worked with self-signed certs, because I haven’t paid any attention to that since moving to Let’s Encrypt).

And sometimes it’s good to resurrect a thread when you have new information of the situation has changed. I’m quite happy with Davdroid now, and have been running it for about 6 months or so. Thanks for the self-cert clarification!

Thanks for your understanding! We’re using Let’s Encrypt, too, and it’s very useful and I’m happy about it :slight_smile: However there are still many use cases for self-signed certificates, for instance home NAS systems which are not accessible from (all) public IPs (and thus can’t get a Let’s Encrypt certificate).