Nextcloud client crashes on OSX 10.13.6 Sierra

I’ve not upgraded my osx nextcloud client in over a year. Not sure what version I was using before, but the latest version today starts, quickly syncs, I see the green checkmark, then it crashes. A quick check of my log doesn’t show anything. There’s still a process running in my ram.
I’m unable to upgrade my laptop beyond 10.13, reasons unknown. My macbook is only about 10 years old, which I do not consider to be that old.
I’ve tried compiling from source from github but that fails after a rabbit hole of ‘legacy cmake crap’.

I’m at the end of my patience. I also tried looking for a ‘owncloud 2.4.0’ version, but cannot find that either. Yes, I’ve found the ‘solved’ thread on here, but that doesn’t help me either.

Since I plan on using this ‘legacy’ macbook for many years, I need a solution that will last me a long time. Preferable a nextcloud (not owncloud) solution. One that, if ever needed, I can EASILY upgrade again.

I thought I’d try to solve my issue by using a docker container, but just hit a dead end there too, need osx 10.15 or higher. sigh.

Any ideas? Thanks!

Oddly enuf, I just ran across an old legacy nextcloud versions page and tried 2.3.3, which appears to be working. It also says it’s ‘up to date’ on the update checker under it’s settings.
Anyway, assuming this will sync my stuff, I may be gtg now.