Nextcloud Client asks for password every time it starts

Nextcloud client version: 2.3.3
Nextcloud version: 12.0.5snap1
Operating system and version: Xubuntu 16.04.4
Apache or nginx version: 2.4
PHP version: 7.1

Hi everyone. I hope you’re OK.

I installed the Nextcloud server snap on a VPS and installed the Nextcloud Client on my Xubuntu desktop computer a couple of weeks ago. Ever since I installed the desktop client, I’ve been getting this message when I open it (I disabled its launching at system start.):

2018-03-07_13-35-32_Nextcloud-Client-Issues

I’ve tried the PPA, snap and AppImage versions of the client and it happens with all of them. As far as I can tell, the issue has something to do with the wallet manager. When I googled this issue, I found that it had been reported in ownCloud back in the day:

Reading from keychain failed with fatal error: ‘Could not open wallet: org.freedesktop.DBus.Error.NoReply; Message recipient disconnected from message bus without replying’

I tried the Arch Linux solutions proposed in this post but nothing changed.

Steps to replicate it:

  1. Install Nextcloud Client on Xfce in Ubuntu (PPA, snap package or AppImage)
  2. Connect to Nextcloud server and authenticate with your password
  3. Quit the Nextcloud Client
  4. Connect to Nextcloud server again and you get the message

I hope you can some light on how to solve this is issue. I appreciate your help.

Thanks a lot,
ndru

I think you’re right when you say it is a wallet issue. I’ve had this with KDE where you would have to type in the password for your password manager, since that is storing it. It could be that it isn’t unlocking? I also had this happen semi-recently with GNOME when Linux got the meltdown patch. Maybe try opening the password manager for xfce at login before you get that prompt and see if it requires you login…that could fix the issue

1 Like

Thanks for the suggestion, @stratacast. It actually solved the problem. I’ve had all kind of weird issues with gnome-keyring in Xfce on different distros (Arch-based ones, Debian, Tumbleweed and Xubuntu). I just ran

rm -v ~/.local/share/keyrings/*.keyring

and rebooted.

After that, I assigned a new password to the keyring, rebooted again and when asked if I wanted to unlock the keyring at session start, I said yes. And voilà. That was it. I can now launch the Nextcloud client without having to type my password over and over again.

Thanks for your help! I really appreciate it.

2 Likes

Hi,

I have a problem along similar lines. I am running the latest nextcloud sync client on Mint 18.3 Cinnamon. I regularly got an error on shutdown saying that the gnome-keyring-daemon was running and this window gave a ‘shutdown anyway’ button (and nothing happened until that button was pressed). My search for solutions found a solution where the ‘execute as program’ permission was removed from gnome-keyring-daemon. This solved the shutdown problem but then required the entry of a password to start the sync client.

Is this combination unique to Mint/Cinnamon? Is there a solution?

Thanks in advance for any advice.
Peter

I tried - but unfortunately I could not get it to work. Working with Cinnamon Mate 19 (Bionic).

I deleted the *.keyring using the line you mention above.

However, it is unclear to me how you assign a new password to the keyring. Which software or app do you use to do that?

hi,

i have the same issue with Linux Mint 19 Mate Edition.
Every start of the Netbook it asks for the password. Very frustrating…

Yep same :\

The same issue here. Mint 19 Cinnamon. Nextcloud client and ownCloud too, everything with very last updates. I’ve removed ~/.local/share/keyrings/*.keyring and rebooted. Evolution stores each password, NC and oC not … :frowning:

apt install libgnome-keyring0

You will be asked for password once more and then it will log in automatically.

Enjoy
PL

1 Like

I encountered this recently in my Linux notebook (ArchLinux + XFCE desktop). Tried these before NextCloud remembers its password (maybe not all of them are necessary):

  • ensure~/.local/share/keyrings/ exists and is a writable directory
  • Install gnome-keyring package
  • in XFCE Session and Startup -- Application Autostart settings, enable a few keyring-like entries
1 Like

I also had similar problem, soved once by creating this symlink ln -s /usr/bin/kwalletd5 /usr/bin/kwalletd and on other computer by installing kwalletmanager

On my desktop computer (Xubuntu 18.04) I had the same issue when using Nextcloud client as snap. After I had installed the password manager Seahorse and had generated an entry Nextcloud with its password, Nextcloud will auto login every time, when I start Nextcloud client. For this behaviour, it is not necessary, to have Seahorse running, before starting Nextcloud client.

My Laptop has the exactly same Xubuntu installation. Even after installation of Seahorse and all the same settings like on my desktop, it does not work: I have to tpe in the password every time, after having started Nextcloud client.

I cannot find out any differences between both computers or their settings!

On my laptop, I followed the proposal of “esprit-libre” and did create the symlink. Nothing changed, when I tried to start Nextcloud.

I followed the advice of jokester and saw, that .local/share/keyrings/ is writable. Gnome-keyring package has been already installed. And in autostart, all keyring elements are activated.

I tried the hint of “plrunner” and did install apt instll libgnome-keyring0. This had not been installed but it was installed now. But no effort.

After removing ~/.local/share/keyrings/*.keyring and rebooting, the same problem: I had to login in Nextcloud manually.

Then I started Seahorse and createdd the entry “Nextcloud” and its password. The file login.keyring did change its change date. So I can be sure, that the password is stored there.

After rebooting, the problem with autologin keeps on.

Sorry, I have no solution, even in spite, I have a desktop computer with no additional installation like libgnome-keyring0 and there the auto login does work flawless!

Just found the really helpfull answer in the Snapcraft forum:

You have to install a passwordmanager like Seahorse and define the password for your Nextcloud. After that you should type: sudo snap connect nextcloud-client:password-manager-service

After this, you start Nextcloud only one more time, needing manually typed password. When you close Nextcloud and start it again, it will successfully auto login. It is not required, to have Seahorse running when starting Nextcloud with auto login.