NextCloud Client 2.6.0 - Link Teilen / Share / Freigabe

Hallo,

mit dem neuen “NextCloud Client 2.6.0” kann ich keine “Links teilen”, es erscheint das Kreisel und es tut sich nix weiter.

16.0.5 NextCloud Server, Ubuntu 18.04.3 LTS, PHP 7.3.
Hat jemand ein ähnliches Problem, welche Logs wären hilfreich?

PS: Über das Webinterface lassen sich die “Links” ohne Probleme erzeugen.

Danke und viele Grüße

Hi,
ich weiß nicht, ob ich ganz verstanden habe, was Du meinst.
Ich habe jetzt mal mit dem NC-Client (2.6.0) einen Ordner synchronisiert, der mit mir geteilt wurde (also in meinem NC als “Link” auftaucht).
Das hat funktioniert.
Ist es das, was Du meintest?

Hi, nicht ganz :wink:

Ich meinte selbst eine Datei/Ordner via Link zu teilen.
Also Windows Explorer --> NextCloud-Pfad --> eine Datei/Ordner auswählen --> rechtsklick --> “Share via Nextcloud” -> "Share Options --> “Link teilen” “+”

Ich habe inzwischen rausgefunden das es schon mit der NC Client Version 2.5.3 Probleme gibt. Mit der Ver 2.5.2 funktioniert es bestens. Bei der Ver 2.5.2 gibt es jedoch noch ein “Aktivieren” Feld was man auswählen muss, dies ist ab der Ver 2.5.3 nicht mehr enthalten?

Besten Dank für die Unterstützung.

Wir haben den Fehler hier auch.

Da das Feature von unserern Usern aktiv genutzt wird, sind wir immer noch auf Client V2.3.3. Das ist die letzte Win Version in der, soweit ich weiss, das Teilen per Link via Client funktioniert. Wir haben V2.5 und V2.6er Clients getestet. Bei beiden funktioniert die Teilen Funktion via Link nicht.

Auf Github gibt zumindest mal ein Issue: https://github.com/nextcloud/desktop/issues/1505 wurde aber von den NC Entwicklern noch nicht kommentiert. Vielleicht gibt es da noch andere Einträge, hab aber auf die schnelle keine gefunden.

Wir sind übrigends aktuell auf NC V16.0.4

Viele Grüße
Marco

Kleiner Nachtrag: Gerande noch -halb- :slight_smile: zufällig das hier gefunden:

https://github.com/nextcloud/desktop/issues/1485

Das könntete Du ja mal probieren. Für uns ist das kein Weg, da wir uns das erzwingen eines Passwortes bei Links sehr wichtig ist.

Hallo Marco, dein Feedback beruhigt mich etwas, ich habe den ganzen Vormittag nach einer Lösung bzw. nach dem Problem gesucht und bin schon daran fast verzweifelt. Da scheint wirklich ein Bug in der Maske zu sein, in unserer Umgebung können wir das Passwort auch nicht wirklich “entfernen” und erzwingen es ebenso. Zum Testen habe ich es trotzdem einmal kurzzeitig deaktiviert und siehe da, es funktioniert. Das witzige, wenn man einen weiteren Link hinzufügt und vorher wieder das PW erzwingt, funktioniert es auch. Nur bei einer komplett neuen Freigabe kommt es zum Fehler, komisch dass das bisher noch niemanden aufgefallen ist… Diese Funktion scheint nicht großartig genutzt zu werden?! (Was ich nicht nachvollziehen kann). Eine Frage noch, die Freigabe über das Smartphone (iOS) funktioniert bei uns ebenso nicht, kannst du das auch bestätigen? VG, Georg

Hallo Georg,

das mit dem Smarthone (iOS) kann ich bestätigen (zumindest in der aktuellen iOS Version). Beim Android Client scheint das Teilen zu funktionieren. (Hatte ich gestern gerade probiert, war aber ein Test-Gerät das von den Apps her nicht ganz aktuell war.)

Grüsse
Marco

Hallo Georg,

kleine Info: mit dem aktuellen Nextcloud iOS Client (V2.24.3.1) funktioniert das Teilen von Links wieder, wenn im Server die Konfig “Passwort erzwingen” gesetzt ist.

Grüsse
Marco

nextcloud 16.0.4
############

Kann das Problem bestätigen, Passwort erzwingen ist wohl der Auslöser, allerdings nur bei einem Windows Client > 2.5.2.

WEBUI und Smartphone Apps funktionieren.

LG

Servus,
ich hatte auch dieses Problem mit dem Windows Client 2.6.2.
Aber nach dem Update auf Version 2.6.3 funktioniert wieder alles wunderbar.

(Nextcloud 17.0.3)
LG