Nextcloud Client 2.5.2 wont start on Windows 10 (after windows update)

file_github_issue
win_10
#1

Hi everybody
Today my Windows 10 installed this update:
2019-05 Cumulative Update for Windows 10 Version 1607 for x64-based Systems (KB4494440)

Now my Nextcoud client does not start. It does not give me any error. The mouse pointer changes to “hourglass” for a second or two, and then nothing happens…

I had the same problem last week, when I first installed NC client, but previous windows update seems to solve it. Now, new update seems to break things again.
Does anyone know how can I solve this, or does anyone else have this problem?

#2

You can start the client from commandline (cmd.exe) and enable logging:
https://docs.nextcloud.com/desktop/2.5/troubleshooting.html#saving-files-directly

With this information you can create a bug report on https://github.com/nextcloud/desktop/issues

#3

I started client with logging enabled but the program does not write any logging information (I tried both options with ----logfile and --logdir options)
In the meantime I received new Windows update, I will install it now and see what happens…

#4

Installing of new “Cumulative update” KB4505052 have not helped.
Program now crashes with message “Nextcloud has stopped working…” and I do not see any logs written.
I noticed that installer installed Nextcloud in C:\Program Files (x86)\ folder although I have 64-bit Windows.

#5

We could only help you here if there were a clear and easy to debug message in the logs. If it is unkown like this, better get in touch with the developers on github directly. Only thing that pops up could be some permission issue that there is not even a log file written (or something is really wrong in the program that it crashes before). If you create an issue on the bug tracker, please leave a link here so other can follow the discussion.

#6

I did the following:

  1. In Advanced Options of Update settings, I turned off “Defer feature updates” that was turned on since I get my laptop
  2. I updated Windows

Now Nextcloud client 2.5.2. works fine
P.S. I no longer have option “Defer feature updates” in Widows Update settings. :slight_smile: