Nextcloud can't log out

Hi all well i took the jump and updated owncloud to nextcloud, much less headaches than i expected. in fact the only issue was needing to change few folder permissions for the new nextcloud directory.

here’s a quick run down of what i’ve done, i’m running omv (open media vault)
created a new folder called nexcloud, copied data and config from my old owncloud directory. then copied the nextcloud files into my new directory.
I stopped the owncloud service, opened nginx where i told the plugin where the new folder is. enabled the plugin.
i then went to the nextcloud url was greeted with the next cloud page with some errors about folder permissions. i opened the root directory in omv and changed the permissions to www-data.
I reloaded the nexcloud page and the install started. after the install (i used 9.0.54) i logged in as admin and ran the update. I had no errors or issue’s other than my php being out of date.
I played with a few pages as admin, changed picture, set up email, ect. i then tried to log out as i wanted to login as my user. and the page errors out.
here’s the url that loads
Any help would be much appreciated.

Can you tell us which version you are using? If errors are show, please tell us exactly which message and check your logfiles for more details as well.

only logs i can find are about sync issue’s.
this is what chrome shows,
This site can’t be reached refused to connect.
Search Google for index php log out

No logs about nextcloud in omv.

here’s something i tried.
i closed the nextcloud tab in chrome.
I opened firefox and loaded the nextcloud page. i was able to see the login window.
I entered my user name and password and logged in.
Here’s the thing i get unable to connect, here’s the message in the window.
Unable to connect

Firefox can’t establish a connection to the server at

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer’s network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

Here’s the url it try’s to load,

Now if i put in the url and hit enter it logs right in.
I’m thinking it has something to do with loading http and https.

found this in my logs:
{“reqId”:“fSyU/reL9FIPL0IVO5d6”,“remoteAddr”:"::ffff:",“app”:“core”,“message”:“Trusted domain error. “::ffff:” tried to access using “” as host.”,“level”:2,“time”:“2016-12-10T15:02:01+00:00”,“method”:“GET”,“url”:"/cron.php",“user”:“admin”,“version”:“”}

You can add another trusted domain in your configuration file /path/to/nextcloud/config.php. For the temporary error, check as well your webserver logfiles, there should be more information (in case the trusted domain doesn’t fix it completely).

well i have both my dyn and local ip in my trusted domains.

i can login and log out not using https

as soon as i use https i can’t log out.
my omv version is 202.13
nextcloud version is latest stable (10.0.2)

I had the same issue.
I can logout successfully with http.
When use https, I can not logout.

I have add one line
header("location: /");exit();

to nextcloud/lib/private/User/Session.php line 883 to the logout funciton
Which I know is very ugly.

I’d check your config.php and put everything to https by default. I am not sure what exactly is failing, perhaps you opened the session via http or it redirects to http for the logout?

Modifying the code is a temporary fix, perhaps checkout on the bug tracker for similar issues and if not post yours with the modification you did. Either there is something wrong in your settings or your solution could be a fix for certain setups.