Nextcloud can't detect Hard Drive which connect via USB 3.0

Hi everyone,

I created the nextcloud base on ubuntu server recently. It worked very well with my installed SSD 128G inside. But I’m considering to expand my storage with 500G HDD. Unfortunately, my device does not support Sata interface then I have to use my HDD box (connect via USB 3.0).
The connection was established without any issues, I mounted and can copy file to my HDD.
The thing here is I can’t find my HDD shown on nextcloud dashboard, and I can’t link the “external storage” in system as well.
So why it happen? Whether system can’t use the external drive via USB interface and I have to upgrade my storage by extending SSD volumn.
P/s: I also try to move the data directory kn PHP script and it work. But somehow I can’t write data (read only), I don’t think it’s the best solution because I want to use both of hard drive to store (too bad when we waste the volumn)
Hope for any one get similar issue and resolved it absolutely.


To be able to recognize any folder or file on your server, Nextcloud needs to be able to access it. This means you need to make sure that the user, under which the web server is running, e.g. ‘wwwrun’ or ‘www-data’, can access it. Otherwise Nextcloud won’t be able to see it as well.

Yes, I toltally agree with you about that and I tried it once, you can see in this image.
I also set the permission, owner and group to allow nextcloud access ==> But System still got something wrong.