Nextcloud calender has stopped syncing with Mac Calendar using CalDAV

Resolved - when copying my password it was copying a space at the end…

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 18.0.2): 18.0.4
Operating system and version (eg, Ubuntu 20.04): 18.0.4
Apache or nginx version (eg, Apache 2.4.25): nginx/1.16.1
PHP version (eg, 7.1): 7.3.17

The issue you are facing:
I set up Nextcloud yesterday and pulled in my calendar via Apple Calendar app OS X. I had to use an app password because I had 2FA set up on my main nextcloud account and it worked well. Today I added the same calendar to my iPhone Calendar and it worked. However, shortly after that my Mac OS X Calendar would not connect.

I removed the CalDAV account on my Mac and tried to re-add it but it gives me the error “Unable to verify account name or password”.

Note - it’s weird that from my laptop when I do ping mynextcloud.server, ping cannot resolve (unknown host). But I can browse mynextcloud.server in my browser completely fine. There are no proxies/VPNs running. When I tether my phone’s internet connection to my Mac and try to connect via Mac OS Calendar it takes a bit longer but again returns the same “Unable to verify account name or password”.

Here’s what I have tried and checked:

  • Created a new app password and given these new credentials. They work fine again on my iPhone but not on Mac Calendar.

  • Disabled local firewall and as well as UFW on my server. No luck.

  • Truncted the oc_bruteforce_attempts table in the MariaDB database NextCloud connects to. I found this suggestion on another topic on these forums.

Is this the first time you’ve seen this error? (Y/N): Y