Nextcloud calendar app subscribing to Google Calendar not working, no solution found worked

Software version:

  • Calendar 2.0.3
  • Nextcloud 18.0.6 (installed through snap, on Ubuntu 20.04)


Need to subscribe to a public Google Calendar (work related, managed by others)
I can only find its public URL (don’t think it’s ics format), starting with https://

subscribed through link, no error message, name of this calendar shown as “
never updated (longest wait time: 24 hr)

Googled around and found these articles, none worked:

I’m super confused and frustrated. Any thoughts and suggestions will be appreciated!

Please make sure that your Nextcloud cron job is running regularly as described here. If this job isn’t running on a regular base, adjusting any interval has no effect on anything :wink:

If you can’t find occ running occ commands won’t do anything…

Thank you @j-ed and @tcit for your replies! I digged into the issues you mentioned and, though not solved yet, found some more clues to this issue:

  1. I installed Nextcloud with snap and found one post mentioned that some instructions will have to be run differently for a snap installation
    Permissions Issue with Data Storage "Snap" - Solved

  2. I tried setting cron jobs for either www-data or root but none actually ran

  3. I manually ran the cron job by sudo php /snap/nextcloud/current/htdocs/cron.php and got this error message:

App directory "/snap//current/htdocs/apps" not found! Please put the Nextcloud apps folder in the Nextcloud folder or the folder above. You can also configure the location in the config.php file.

That seems like it didn’t get the path correctly, as there is a folder called /snap/nextcloud/current/htdocs/apps. I recalled when digging in one of the config.php files that position of the path was $SNAP_NAME. I added export SNAP_NAME="nextcloud" and confirmed this environment variable is loaded by sudo echo $SNAP_NAME. But running the cron job manually again yielded the same error message.

Any thoughts on this?

did you found a solution for this?

Im having the same problem. The Nextcloud instance is inside a VPN, so not accessible from the outside, but that shouldnt be a problem.

I ahve set php occ config:app:set dav calendarSubscriptionRefreshRate --value "PT1S" to 1 Second as well and crons are working.

I dont get any events from my google calendar into my next cloud calendar.

My Nextcloud version is 21.0.4 and installed via Helm (Docker)
And Calendar is of version 3.3.2


made it work - I just copied the wrong link from the google calendar.
Go to your Calendar settings and copy the link from “Secret address in iCal format” - that one works. all the other links do not work.