Nextcloud Box Problems

Having just received my box and trying to set it up following the wiki, I seem to have fallen at almost the first hurdle.

In adding my external domain into Nextcloud, I have to use sudo nextcloud.occ config:system:get trusted_domains in the terminal to list the domains I am currently using. However when I do that I get the following:-

ubuntu@nextcloud:~$ sudo nextcloud.occ config:system:get trusted_domains
[sudo] password for ubuntu:
ERROR: ld.so: object ‘/usr/lib/arm-linux-gnueabihf/libarmmem.so’ from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object ‘/usr/lib/arm-linux-gnueabihf/libarmmem.so’ from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object ‘/usr/lib/arm-linux-gnueabihf/libarmmem.so’ from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object ‘/usr/lib/arm-linux-gnueabihf/libarmmem.so’ from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
The process control (PCNTL) extensions are required in case you want to interrupt long running commands - see http://php.net/manual/en/book.pcntl.php
192.168.0.5

How can I proceed ?

Fist recommendation, after doing some research and writing the following:

$ sudo rpi-update

It will update your firmware to the newest bleeding edge and therefore should update all the arm libraries. Try this, before you go on reading my ideas :stuck_out_tongue:.



I don’t use snappy ubuntu, nor does the “fix” I found is for it, nor do I have deeper understanding about the preload of libarmmem.so or if/why it is necessary for running the occ command. So the following is just a hint where to start ;):

ld.so is the dynamic linker of the system which links to shared objects/libraries as requested by a program/script: http://man7.org/linux/man-pages/man8/ld.so.8.html
/etc/ld.so.preload contains objects that seem to be always preloaded, when ld.so is used.

The nextcloud.occ command also uses ld.so and therefore the list of files in /etc/ld.so.preload is also preloaded. It (in my case) really and only contains libarmmem.so. The preload of it fails in your case. You could check if /usr/lib/arm-linux-gnueabihf/libarmmem.so really exists.

If it does exist and the error reason is a different one, you COULD try to comment out the line from /etc/ld.so.preload, as mentioned for fix in the link above. But as I said I have no idea how this could effect the remaining behaviour of your system… As fare as I can extract from here, it is not necessary for the system to run, but to speeds it up.

Thanks for the reply. I tried rpi-update but that didn’t change anything.

I confirmed that the file /usr/lib/arm-linux-gnueabihf/libarmmem.so existed and tried commenting out the only line in /etc/ld.so.preload. That had some effect but I still got the following after trying sudo nextcloud.occ config:system:get trusted_domains:-

ubuntu@nextcloud:~$ sudo nextcloud.occ config:system:get trusted_domains
The process control (PCNTL) extensions are required in case you want to interrupt long running commands - see http://php.net/manual/en/book.pcntl.php
192.168.0.5

Hmm, maybe that again is related to the not preloaded libarmmem.so, but I am not sure, nor did I find some connection/requirement for PCNTL extensions and that library.

Sorry, at that point I am at the end of my ideas. I hope someone with more knowledge about that arm library, PHP, or responsible for nextcloud box, can solve this with you.
To not forget it, better change the /etc/ld.so.preload back to original and just keep it in mind, as the error messages of both states are now reported here.

I’m getting this problem too
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.

It’s a great pity that there doesn’t seem to be a way of solving these sort of problems for the non technical amongst us. I think I will send the Box back for a refund.

I’d suggest reflashing the image, as it’s not an issue I’ve run into across several system setups. All it takes is a download of the official image and something like Rufus on windows to write it to an SD card, at which point it’ll reinstall the disk from scratch and you can try again.

Thanks Jason,
It took me days to load all the stuff onto the hard disk - I won’t have to do this again will I?

Have a look here for reinstalling without a full wipe.

:slight_smile:

hi jason,
I did a reinstall with the image, and still getting the same problem:

root@nextcloud:/snap/bin# ./nextcloud.enable-https -h
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/lib/arm-linux-gnueabihf/libarmmem.so' from /etc/ld.so.preload cannot be preloaded (cannot open shared object file): ignored.
Usage:
    nextcloud.enable-https -h
    Display this help message.

    nextcloud.enable-https <subcommand> [OPTIONS]
    Run the provided subcommand.

Available subcommands:
    lets-encrypt [OPTIONS]
    Obtain a certificate from Let's Encrypt and automatically keep it
    up-to-date.

    self-signed
    Generate and use a self-signed certificate. This is easier to
    setup than Let's Encrypt certificates, but will cause warnings in
    browsers.

    custom [OPTIONS]
    Use certificates generated by other means.
root@nextcloud:/snap/bin#

still no solution to it?
thx

I’d suggest you create an issue here:

There’s no guarantee of a solution via the forum as the issues are ultimately only properly tracked on GitHub. With an issue in place you can keep an eye on progress.

These look like (admittedly ugly) nonfatal warnings. Are they actually causing problems?

ubuntu@nextcloud:~$ sudo nextcloud.occ config:system:get trusted_domains
The process control (PCNTL) extensions are required in case you want to interrupt long running commands - see http://php.net/manual/en/book.pcntl.php2
192.168.0.5

That output looks perfectly reasonable and expected.