NextCloud Box access

Hello everyone,

I’ve setup the Nextcloud box and everything works fine locally i’m able to access and transfer my files.
Do you know how I can access it when I am out of home? A possible solution I had in mind would be to open a port on my router and then get a hostname (from for example) for ddns; however, when I tried to enter: hostname:port i got the following message:

‘‘You are accessing the server from an untrusted domain.
Please contact your administrator. If you are an administrator of this instance, configure the “trusted_domains” setting in config/config.php. An example configuration is provided in config/config.sample.php.
Depending on your configuration, as an administrator you might also be able to use the button below to trust this domain.’’

Thanks a lot in advance for your help!

a40ntistos, let me know if this helps:

command not found - nextcloud.enable-https
?? Thanks in advance.

Maybe you forgot to use sudo?

No, I did use sudo. I am completely new to snap, lxc, docker or whatever is hiding nextcloud on the nextcloud box. Logging on to the nextcloud server box and using sudo still does not reveal nextcloud although nextcloud operates properly from a user browser on another computer on the local net. Is there a good reference to understand this better?

That’s interesting. What do you see when typing:

$ ls -altrs /snap/bin


$ snap list


$ uname -a

ls -altrs /snap/bin
4 drwxr-xr-x 5 root root 4096 Aug 25 05:22 …
4 -rwxr-xr-x 1 root root 719 Sep 24 03:04 nextcloud.enable-https
4 -rwxr-xr-x 1 root root 719 Sep 24 03:04 nextcloud.mysql-client
4 -rwxr-xr-x 1 root root 723 Sep 24 03:04 nextcloud.disable-https
4 -rwxr-xr-x 1 root root 683 Sep 24 03:04 nextcloud.occ
4 drwxr-xr-x 2 root root 4096 Sep 24 03:04 .

snap list
Name Version Rev Developer Notes
nextcloud 9.0.53snap3 70 nextcloud -
ubuntu-core 16.04.1 424 canonical -

uname -a
Linux ubuntu-standard 4.4.0-1017-raspi2 #23-Ubuntu SMP Thu Jun 30 21:50:40 UTC 2016 armv7l armv7l armv7l GNU/Linux

Everything seems normal, so I don’t understand why your system can’t find the command.

Try with the prefix:
$ /snap/bin/nextcloud.enable-https

Thanks Oparoz! Just a matter of knowing where to look. Works now. Guess I need to learn more about Snap. I appreciate your patience.

1 Like

I am using this setup in the link provided to have next cloud running. I was able to install and configure my ssl. I just cant figure out how to access the trustdomain section so I can add my domain.Any solutions?