Nextcloud blocks any changes


I want to downsize the pictures in nextcloud with mogrify(and adding text on it). That works fine.
The problem is that nextcloud doesn’t accept any changes. The preview is the old one and the file size is not updated.
I can’t download the picture and get an network error.

If I want to delete the file over nextcloud, I also get an error.
I have to delete the file over the console and then over nextcloud.

chmod ugo+wrx mypicture.jpg allows nextcloud to rename and delete the file but the download still doesn’t work.

I run the mogrify command at the moment as root, later with crontab.

My system:
Ubunut 16.04 LTS.
Nextcloud in docker.

Have you tried rescanning the files?

Now I can download the picture but get a .jpg.crdownload file. Without chmod, renaming and removing still doesn’t work.
The preview is also the old one.

Please don’t perform manual changes in the data folder with some kind of scripts. This is not really something that we advocate to do as you bypass the filecache etc.

If you want to do minifications the proper way would be to write a Nextcloud app that has a CLI command which runs the minifications. This way you properly operate on the files in a way that Nextcloud is aware of.

1 Like