Nextcloud Android Client App - can't find the host - help required

Hello together,
i dont’ know what to do any more. My nextcloud works fine with the Windows client and i can connect to the cloud via internetbrowser (mobile network and home network). Only the android app can’t connect. I always get the message “can’t find the host”

My setup is:

  • internet provider: WillyTel (Glasfaserleitung)
  • lokale Server
  • Raspberry PI 4 (8GB)
  • OS: official Raspbian Buster
  • PHP: Version 7.4.16
  • MariaDB: Version 10.3.27
  • nginx: Version 1.14.2
  • Nextcloud: Version 21.0.0
    The raspberry is connected to my fritzbox. I have a domain at Freenom and put the myfritz adress as a nameserver. Portforwarding in my fritzbox is enabled for port 80 and port 443

My nginx.conf:

user www-data;
worker_processes auto;
pid /var/run/nginx.pid;
events {
worker_connections 1024;
multi_accept on; use epoll;
}
http {
server_names_hash_bucket_size 64;
access_log /var/log/nginx/access.log;
error_log /var/log/nginx/error.log warn;
set_real_ip_from 127.0.0.1;
#optional, Sie können das eigene Subnetz ergänzen, bspw.:
set_real_ip_from xxx.xxx.xxx.x/xx;
real_ip_header X-Forwarded-For;
real_ip_recursive on;
include /etc/nginx/mime.types;
default_type application/octet-stream;
sendfile on;
end_timeout 3600;
tcp_nopush on;
tcp_nodelay on;
open_file_cache max=500 inactive=10m;
open_file_cache_errors on;
keepalive_timeout 65;
reset_timedout_connection on;
server_tokens off;
resolver 127.0.0.53 valid=30s;
resolver_timeout 5s;
include /etc/nginx/conf.d/.conf;*
}

I hope anyone can help me.

Regards
Florian

Hey @fifu and welcome to the user-forum on Nextcloud.

Thanks for your first participation in the project.

Pls remember that we don’t want any other language than english on the int’l part of the forum :wink:

I wanted to ask you: have you tried different cell-phones? And what about the config/setup/environment of your cellphone?

I just visited the forum to start the exact same thread. I am happy that I am not alone. I have the problem that my NC App doesn’t find the host. When I turn off wifi and connect via mobile data it finds the server. If I turn wifi back on, the connection is lost again. I have the same problem on my wifes phone. Even though, I thought it worked on my wifes phone when I tested it a few weeks back.

Connecting via the phones browser as well as the Windows client work.

My phone is an LG G8S Thinq running Android 10 and I am using version 3.15.1 of the app. My wife’s phone is a Fairphone 3+ running on Android 9. Is there an easy option to access log files of the Android client? There is (obviously) nothing on the servers log.

I am running NC 20.0.7 in a Docker container behind a Traefik reverse proxy. Besides this Android issue, I haven’t experienced any connection issues.

Hey JimmyKater,

thanks for your replay.
I deleted the german part :slight_smile:
I tryed it on an Samsung S7, Samsung S9 and an Huawai Tablet. I allways egt the same massage.

Wich config/setup/environment regarding the mobile do you think off?

@dennisw : My problem ist slightly diffrent. My android client can’t connect in homenetwork nor in mobile data. Via internetbrowser i can connect to my server via Homenetwork and mobile data

Thanks
Florian

Which OS? Any anti-virus, anti-script or anti-whatever apps installed?

Hey JimmyKater,

Samsung S9 = Android 10.0
Huawai tablet = Android 7.0

no apps install (so far as i know) an found on my research.

What i find reall strenght is that i can log in from windows client and also from the mobile phone and the tablet (mobile data and W-Lan) so long as i use the internetbrowser. When i use the app i still get the message “can’t find the host” or “no connection possible”

This is the protocoll screen from the nextcloud web interface:
protocol_screen (2)

Hi,

I am really by no means an expert. But as far as I know, the difference between web browser access and Android App access is that the App uses WebDAV interface. May be there is a missconfiguration in the config files of nextcloud in this area.
This would be the direction I would investigate further.

By the way - the repeated messages ,login failed ’ are feom you app ?
Oliver

For me, WebDAV seems to work fine. A connection via Windows Explorer or WebDAV Navigator on Android (Wifi or 4G) works fine. But the app still cannot find the host.

I also got a few failed logins in the log from testing WebDAV with my phone and PC. I was wondering about the IP address shown. In my case, it was 141.101.104.74 and 141.101.77.163. Which neither look like the local IP addresses (including my docker network) nor my public IP addresses (cable/4G). @fifu do you know the IP address logged in your case? I think the log entries should be unrelated. The Android App cannot reach the server. Therefore, we cannot even enter credentials and attempt to login.

Edit: Just found this thread on IPv6/IPv4 issues that looks promising.

Hey dennisw,

same for me…i don’t know the ip’s in the log.
Is the windows client also based on WebDav? Because the windows client works fine.

I thought, that i elemenated the ipv6/ipv4 problem by having a domain and a cname pointing on the myfritz-adress? I also opened port 80 and 443 for ipv6.

so long…

My setup should exclusively run over IPv4. At least, that’s the address that I forward using a dyndns provider to my DNS provider.

In the thread that I posted, I read that the error only occurs with the newer versions of the app.

I sideloaded version 3.13.0 and it works! So next, I have to figure out how to tell my NC installation that I am only using IPv4.

I assume that there are some issues with my docker configuration. In the settings/overview pane I got the following picture:

No IP address and a 10 Gb/s connection :upside_down_face:

Update: So I tried to deactivate IPv6 by using the workaround described here. Still no connection.

Update 2: Solved it :slight_smile: The problem could be solved by deactivating IPv6 on my routers local network. @fifu if your problem is also IPv6 related you might want to check this bug report.

Hi dennisw,

thanks for your hint. The older version of the android app works for me as well. So i need to search how to configure my serve for the ipv6.
Or better to say i think i need to do so.
At the moment i don’t know how to. My actuall configuration is like this.

I think i get both, ipv4 and ipv6 from my internet provider because when i go to the fritzbox i see the following:

At my domain provider i put the cname for my subdomain and entered the myfritz-adress.
In my nextcloud.conf file i put:
erver {
listen 443 ssl http2;
listen [::]:443 ssl http2;
server_name “subdomain”; (same as the subdomain for my cname)

At the moment i don’t know what to change to get the actaul android app working.

regards
Florian

Hi Florian,

have you solved your issue? You might want to check this steps (German) to deactivate your IPV6 connection on your Fritzbox.

Cheers,

Dennis