Nextcloud Android app does can't find host

Nextcloud version 20.0.2:
Operating system and version Debian 10.6:
Apache version 2.4.38:
PHP version 7.3.19-1:
Android App: 3.14.1

I was running Nextcloud 19.0.5 on a RPi3, but since it was quite slow, I performed a new installation on a new Intel i5 system running debian 10. Everything went fine, with the setup, I have a URL and the corresponding port fw setup in the router to the new machine.
Everything is running smothly on the laptop, using the browser and the Windows client connected to the DuckDNS URL, but when I add the new server in the Android app, it fails with an error saying it can’t find the host server, on the home WiFi network.
I tried to access the server from the mobile browser and it works, but not on the app.

I tried the following connections on the app:

I tied to follow similar issues on the forum with previous Nextcloud versions but no success with any.

I also reverted my DuckDNS URL to point to the previous server, and the app still complains it can’t find the host.

I don’t see anything relevant in my apache logs, I also don’t see anything in the Nextcloud log.

It wroks in the Android browser (tested Chrome and Firefox) but not in the app. It works from the internet but not from the wifi. Is this a problem with the app?

I don’t know what I can do next, or how can I debug this further.
Any ideas anyone?

I just tested with version 3.14.0 and I have the same behavior.

Tested also with version 3.13.1 and it works.

it really seems an issue introduced in the newer 3.14 version of the client.

Someone filled a bug already:

The issue is probably with your ipv6 dns setup. Starting with 3.14.0 ipv6 is prefered over ipv4, so v4 is only used when v6 is not available. In case it is faulty it simply fails (since we can’t destinguish between network setup errors and things like that). So if available it needs to be properly set-up

My Nextcloud server had IPv6 deactivated but DuckDNS had the IPv6 configured. I activated it on the Nextcloud server and it still fails. Then I deactivated it, and removed the IPv6 address from the DuckDNS configuration and it works. I used the latest 3.14.1 version available on the Google Play Store.

1 Like