NextCloud AIO v29 from Docker, external storage bug

I stumbled upon a bug.
My setup. I have a Windos 10 machine with WLS2 subsystem.
Installed Docker Desktop on it.
Then from a cmd I installed NextCloud AIO v29.
The problem is External Sorage. I attached a SMB share, also a ftp share from my local netwok NAS server. Both my NAS and my Windows PC, where Docker and NextCloud aer installed, are in the same local network.
I was able to add the needed folders from the sshares as an External Storage, but everytime when I click on a file from this storage i gives me an error. So I can’t visualise it, neither download it. The first error from the logs is: Error index Exception stream_get_contents(): Argument #1 ($stream) must be of type resource, bool given in file ‘/var/www/html/lib/private/Preview/ProviderV2.php’ line 93. The second one is: Error webdav ServiceUnavailable Could not open file.
I couldn’t make it work, so I erased everything and installed a much older version of NextCloud AIO - nextcloud/all-in-one:20230530_084406-latest.
The whole cmd command is as follows:
docker run ^
–sig-proxy=false ^
–name nextcloud-aio-mastercontainer ^
–restart always ^
–publish 80:80 ^
–publish 8080:8080 ^
–publish 8443:8443 ^
–volume nextcloud_aio_mastercontainer:/mnt/docker-aio-config ^
–volume //var/run/docker.sock:/var/run/docker.sock:ro ^
-e NEXTCLOUD_DATADIR=“/run/desktop/mnt/host/d/nextcloud” ^

I’m writing this because I believe this is a bug. I don’t know where else to post it if that’s not the right place.

Thanks. Will be happy to see someone had fixed this bug hor himself/herslef and how can I fix it as well.
Also, will be happy to receive a link to where can I officially report it, if that’s not the place for it.

hi @Fori welcome to the community :handshake:

you didn’t provide enough technical background to understand the issue. For me it sounds like networking or permission issue - check the logs of all components for more details.

In general running an application like Nextcloud in Windows WSL i not a good idea. This might work for testing but long term you will hit technical limitation you can’t solve especially if you are not an expert. Depending on your NAS it might be capable to run Docker containers directly - this definitely much better than #wsl

I encountered a bug with External Storage in NextCloud AIO v29 on Windows 10 with WSL2 and Docker Desktop. Adding SMB and FTP shares works, but clicking on a file results in errors and files cannot be viewed or downloaded. Error logs mention issues with stream_get_contents() and ServiceUnavailable. Reverting to an older NextCloud version didn’t help.

Is this a known issue? Any fixes or guidance on where to officially report this would be appreciated

Hi, @wwe, I don’t know what else should I provide as technical info. Ok, I’ll try to be more informative. My NAS runs on TrueNAS CORE. Its version is TrueNAS-12.0-U8.1. It’s not installed by me and I can’t (don’t want to try to) upgare it to v13. When I last went to it, I noticed that the icons of the official (iXSystems’) plugins are broken. There is a NextCloud plugin there and I tried to install it but seems it’s not supported for this version of TrueNAS anymore - it raises an error. Moreover the NAS’ hardware is very old and it does not have resources to run it. From the other hand, I can access my NAS through Windows SMB shares and was doing it from the beginnig, no issues at all. Every night I back up automatically my projects there.
And lastly, I installed older version of NextCloud in Docker and everything worked out. My SMBs are accessible through NextCloud’s External Storage, so I think it’s a bug in the latest version of NextCloud. I know generally apps have problems with the latest php version (8.x), so I found an old version of NextCloud which uses php v7.4. And it’s all working now.

p.s. I am aware that installing and using something though WSL2 is not a good idea but I don’t have any other options. I suppose i can try some virtualisaton software like VMWare or VirtualBox to run Docker or some kind of Linux, but that will be a long process as well, since I don’t know the concept of Docker and and am not comfortable with Linux.

Same here. Now I use a much older version of NextCloud. I especially wanted one that uses php 7.x. The Exact version is 20230530_084406-latest and it works.

@Fori & @SamuelHernandez:

You’ll need to provide the entire raw log entries / stack traces from the time period of this matter.

Well, can I get a link with some guidance as where to copy the logs from and what exactly should I provide.
For now I can’t get this information because I erased everything and installed an old version of NextCloud AIO and everything works as expected.
But if I decide to try any newer version and I encounter the same problem again, I’ll want to provide the needed logs so the problem be fixed.