Nextcloud AIO Talk notifications problem

Hello!
I am having issues trying to setup nextcloud-aio, especially when it comes to the Talk app. I am unable to receive notifications on the “Nextcloud Talk” app for iOS on my phone (on Android phones everything works).
I am using Nextcloud-AIO installed manually from the terminal on an UnRaid server (Slackware). I was unable to use the docker from the App Store.
Before I move any further I want to say I am a newbie in Linux, this is my second project I’m working on (for personal use).
I have successfully installed NPM and connected it with Nextcloud/Unraid, and am using Cloudflare, I don’t think there are any problems there.
From what I can see I am facing three issues that could cause the notifications to not work on my iPhone (from the Nextcloud Talk app).

  1. “Push server is not a trusted proxy”, although I think I have added all the right stuff in config.php
    https://pastebin.com/AP0zvJu5 - notify_push:self-test
    https://pastebin.com/UgtRsDCt - config. php

  2. Second problem I think it would be the bunch of errors and warning I get when looking in the Nextcloud-talk logs, like “socket: Protocol not supported” and “No wokring ICE candidates returned by the TURN server” when I test from inside the talk settings in NC.
    https://pastebin.com/80znJZvP - talk logs

  3. Probably the real problem, me, like I said I am a newb and learning the terminology and the parsing of the folders, I was unable however to find the turnserver.conf.

I am able to provide any information if requested and guided (if needed).

Thank you!

Nextcloud version (eg, 24.0.1): 23.0.5
Talk Server version (eg, 14.0.2): 13.0.6
Custom Signaling server configured: yes?
Custom TURN server configured: yes
Custom STUN server configured: yes

In case mobile Nextcloud Talk apps are involved:
Talk iOS version (eg, 14.0.2): 14.0.2

The issue you are facing:
Chat notifications not pushing to the Nextcloud Talk app on iOS.

Is this the first time you’ve seen this error? (Y/N): No, but I haven’t managed to find a solution yet.

Steps to replicate it:

  1. Install Unraid on a server
  2. Install Nextcloud-AIO
  3. Test chat notifications on ios

The output of your Nextcloud log in Admin > Logging or errors in nextcloud.log in /var/www/:

https://pastebin.com/NM0pAQS9

The output of your Apache/nginx/system log in /var/log/____:
unable to find

Hey @rdiulian

regarding your first point:

notify_push has nothing to do with push notifications sent to talk devices, it is used to inform clients about changed files for example (see GitHub - nextcloud/notify_push: Update notifications for nextcloud clients or https://nextcloud.com/blog/nextcloud-hub-21-out-with-up-to-10x-better-performance-whiteboard-and-more-collaboration-features/ for some details).

To test push notifications to talk devices you are looking for the occ command notification:test-push --talk youruser. There’s a document to help troubleshoot push notifications for talk iOS:
https://github.com/nextcloud/talk-ios/blob/master/docs/notifications.md

1 Like

Hello @SysKeeper !

This is valuable information, given that I didn’t know the difference between notify_push and notification. Thank you!

I found this page in the past, I tried debugging using the methods in the page, I shall focus a bit more into it, now that I know where to look (not notify_push).
This is the results of notification:test-push:

root@UA:~# sudo docker exec -it nextcloud-aio-nextcloud php occ notification:test-push --talk jly
No devices found for user

The user JLY is signed in on my iOS device, in the Nextcloud Talk app, but no notification on the device. When I do the same test-push to my admin user (which is logged in on the web browser I am currently typing from, I get the notification on my laptop). I also went and tried the macOS app for Nextcloud Talk, and I can confirm that the notifications for messages/mentions get through, it seems the only environment that I have problems with is iOS (tried multiple iOS devices, all have the same problem).

After that I decided to try again after signing out and back in the user on my App and this is the result:

root@UA:~# sudo docker exec -it nextcloud-aio-nextcloud php occ notification:test-push --talk jly
Trying to push to 1 devices

Language is set to en
Private user key size: 1704
Public user key size: 451
Identified 1 Talk devices and 0 others.

Device token:13
Device public key size: 451
Data to encrypt is: {"nid":32,"app":"admin_notification_talk","subject":"Testing push notifications","type":"admin_notifications","id":"62a87c46"}
Signed encrypted push subject
Deleting device because it is unknown by the push server: dQy8gmyxkJ552/A7AQJ+b9CvLWTI2Yp77DtYkzYdN+8iO3Ufqk3fz45L3Fj7RYj1r3dCV93ndyHy6uHIl6e1mw==
Push notification sent, but 1 failed

The push-proxy can be reached using ```
curl https://push-notifications.nextcloud.com

I found this 2 GitHub issue really useful to understand and troubleshoot notify_push (with docker)

review your IP/DNS/TLS/reverse proxy config - something must be wrong there…

webrtc/ICE/TRUN etc is pretty complex technology - using highly standartized solution like AIO might be not the best way if you can’t fullfil it’s prerequisits. maybe the hard way way working through manual docker installation (or using a system where AIO works) is a better way…

These push notifications are sent via a proxy server that is hosted by the Nextcloud GmbH. So I doubt that this is an issue of AIO. Maybe your firewall settings are too strict to let them push to your device correctly?

I thought the same at first, but he said it works fine on android and the push proxy is needed there as well, if I’m not mistaken?!

What I find suspicious is first no talk device was found when running the test command and later the push proxy was unaware of the device so it was deleted (I guess that happened the first time as well). So question is why talk-ios was unable to register at the proxy. Is the iOS device and the android device using the same (wifi) Connection?

Other than that, I agree, I don’t think it’s related to AIO…

1 Like

I have managed to fix that issue temporarily, thank you.

I am starting to think there’s something I am missing, can’t seem to figure out by my own, sadly.

The reason I am using AIO is because it moves much faster than a standalone nextcloud docker file (like the one from linuxserver).

Currently I managed to install Nextcloud-AIO from the UnRaid Apps store, and will manually install Nextcloud-Talk with a custom CoTurn server.

I am not saying there’s a problem with AIO, just to be clear. How would one review said firewall settings? I am unaware of having any firewall set up.

Yes indeed, the push proxy is needed, I can reconfirm that notifications work on Android (Google Pixel 2 XL), the Nextcloud Talk app for Android is a lot more configurable (it gives you more available settings), I am starting to think there is a problem with the iOS app itself.

Yes, but since you asked me I tried with mobile data and the outcome is the same.

Thank you for all your answers.

I guess it was meant like “looks like this is not a specific problem to AIO”, so we don’t waste time looking at AIO for a problem/solution.

I see why you come to this conclusion, but I’m not sure. I’ve just set up a new account in the iOS app and push notifications are working perfectly. What kind of device are you using? Just to rule out any weirdness from iOS, can you try to remove the app and install it again?

Indeed, that’s what I wanted to say. :slight_smile:

I’m testing on an iPhone 13 Pro max running iOS 15.5 and also testing on an iPhone 12 Pro max, running a slighty older version of iOS 15.
I have tried removing the app and installing again multiple times, both of the phones have the same problem.
I noticed that if I install the main “Nextcloud” app, while having the “Nextcloud Talk” app installed on the iOS devices, the push notifications are received by “Nextcloud” app itself, whether it’s a file notification or a chat notification. However when I press on the chat notification after receiving a message, it takes me to the Nextcloud app, instead of the Talk app.

That being said, I am going to install a standalone instance of Nextcloud, configure a CoTurn server myself and test the Talk notifications after, there’s something fishy going on for sure, this way I can, hopefully, identify where the issue is.

EDIT:
@SysKeeper Could you please share info about what iOS device and version you were using when you tested here? :

I even went as far as connecting two accounts on the demo servers from nextcloud (try.nextcloud.com), after I confirmed the two accounts are on the same server, I connected them on two iOS devices using the Nextcloud Talk app to see if the behaviour changes, to my surprise there was no change between using my NC server and the demo.

Nearly the same here!
iPhone 13 Pro, iOS 15.5, Nextcloud 24.0.3, Nextcloud Talk App for iOS 14.0.2

My problem is a missing bubble display of unread messages count on the iOS Nextcloud Talk app symbol!
Generally push notifications are received but only as banner notification messages not as unread bubble on the app itself!

iPhone 13 Pro. To be more precise: I receive banner notifications (if configured, even on my apple watch) but the unread count bubble of the talk app itself is missing!! After opening the talk app I can see the unread count in the entry of the conversation list but not on the talk app itself. It seems to be refreshing after opening the app.

I have tried removing the app and installing again multiple times but no success.
I noticed the same strange behavior as if I install the main “Nextcloud” app, while having the “Nextcloud Talk” app installed on the same iOS devices, the push notifications are received by “Nextcloud” app itself instead of talk app, whether it’s a file notification or a chat notification. However when I press on the chat notification after receiving a message, it takes me to the Nextcloud app, instead of the Talk app.
BUT…
push notifications and bubble count on the talk app work fine on my wife’s iPhone 11 Pro with also iOS 15.5 and the same Talk app 14.0.2 in the same WiFi network. I configured a separate account for her on the same nextcloud instance to test drive the talk-app features with the most current nextcloud server 24.0.3.

The correct unread count bubble info is a killer feature for using Nextcloud Talk in my environment! Any help appreciated!

Thanks Chris

Hey @cw4u
just to rule out the basics, you do have enabled the badge in the iOS setting for Nextcloud Talk, Right?

Sorry @rdiulian I didn’t notice your edit. I usually test with an iPhone 11 Pro running the latest iOS version (probably 15.5 back then) and the latest available version of nextcloud talk on the App Store / Server, so on iOS that would be 14.0.2.

@rdiulian I’m having the same issue. No text notifications on iOS device · Issue #851 · nextcloud/talk-ios · GitHub

Version 14.0.3 was just released which should fix problems in the push subscription process

Depending on how fast the review process at apple takes, it should be available in the next days. Looking forward to some feedback :slight_smile:

2 Likes

Just updated to 14.0.3 and the issue has been fixed for me. I want to thank @SysKeeper for the amazing work. :confetti_ball: :beers:

@SysKeeper : Thanks a lot for answering! Of course I did!
For info: I have the nextcloud files app installed on my mobile too!
I tried already deleting and reinstalling both of the Nextcloud files and talk app (even the testflight version of talk, 14.99.0).
My wife - same setup (iPhone Pro, current iOS and Apps) - has no problems with the notifications.
I found somewhere the hint that if there is a open web browser window on one other device (PC or other mobile) that may cause this issue!
There are a lot devices and I don‘t find anyone left a browser window open :grimacing:.
Is there a way to clean/close all existing sessions of one user, perhaps somewhere inside the administration section of Nextcloud?

@cw4u Ok, so if you do get push notifications and just the bubble is missing, we’re talking about a different issue here.

So let’s see. If you receive a push notification which was successfully decrypted (which I assume is true, because otherwise you wouldn’t see the contents of the notification), the unreadBadgeNumber is increased for the account you received a notification for. Then the unreadBadgeNumber of all accounts is summed up and added to the notifications badge property: talk-ios/NotificationService.m at d1212d5aaa07a4e358a95c4ab6ba45a24ae33dba · nextcloud/talk-ios · GitHub
So that’s pretty straight forward:

Use this property to specify the number to apply to the app’s icon when the notification arrives. If your app isn’t authorized to display badge-based notifications, the system ignores this property.

Specify the number 0 to remove the current badge, if present. Specify a number greater than 0 to display a badge with that number. Specify nil to leave the current badge unchanged.
(Apple Developer Documentation)

At this point I’m still wondering if badges are somehow turnt off on your phone. Do you have any focus settings enabled, which hide notifications badges? Can you access notification settings for Nextcloud Talk in the Settings App or is it missing?

Another test would be to check what happens if you add your account to your wifes phone. This would rule out any problem with other sessions.

Exactly that’s the point. It’s just the bubbles.
I will check your hints and try the account switching on my device and that of my wife and come back to you!
Thanks a lot for your support! :slight_smile: :heart: