Nextcloud AIO setup - submitting the domain leads to 'internal or reserved ip-address' error

Hi!

I had some trouble with my AIO setup a while ago and could not start it up anymore. So i decided to start with a clean slate, following the guide at: GitHub - nextcloud/all-in-one: Nextcloud AIO stands for Nextcloud All In One and provides easy deployment and maintenance with most features included in this one Nextcloud instance..

How i tried to create said clean slate

Here is how to reset the AIO instance properly:

  1. Stop all containers if they are running from the AIO interface
  2. Stop the mastercontainer with sudo docker stop nextcloud-aio-mastercontainer
  3. If the domaincheck container is still running, stop it with sudo docker stop nextcloud-aio-domaincheck
  4. Check which containers are stopped: sudo docker ps --filter "status=exited"
  5. Now remove all these stopped containers with sudo docker container prune
  6. Delete the docker network with sudo docker network rm nextcloud-aio
  7. Check which volumes are dangling with sudo docker volume ls --filter "dangling=true"
  8. Now remove all these dangling volumes: sudo docker volume prune (on Windows you might need to remove some volumes afterwards manually with docker volume rm nextcloud_aio_backupdir, docker volume rm nextcloud_aio_nextcloud_datadir)
  9. Optional: You can remove all docker images with sudo docker image prune -a.
  10. And you are done! Now feel free to start over with the recommended docker run command!

But now after running nextcloud-aio again, i do get an error when trying to submit my domain:

I see that he complains about my domain (in the form of (mydomain.ddns.net) ip-address on my mashine. Maybe the problem is, that when i execute:

dig +short mydomain.ddns.net

He does show me my local ip:

192.168.178.XX

But maybe it should be something public instead? But i am not totally sure why it resolves this to something local in the first place.
I did connect my local fritz box with my domain provider, so this should not be the problem.

Does any of you have an idea or opinion on this? Anything might be helpful!

Yes, it should be :+1:

A different way would be restoring a backup that you took before on the old AIO instance which would skip the domain verification. But obviously you need to know its location on the host and its password…

Hi szaimen, thanks for your answer!
Why is it local in the first place? I would change it if i knew how :man_shrugging: or why it is like that.

I assume you refer to the borg backup? The first installation was just a test pilot to see if AIO would work, which it did perfectly up until that point of failure of course. So my next top prioritiy is the borg backup :slight_smile:

I don’t know as I do not know your network infrastructure. If you are sure that your domain definitely has the correct public ip-address set (which it does not look like), you should hopefully be able to overwrite the value during the docker run command with --add-host yourdomain.com:<public-ip-address>.

If you mean by my domain, my domain provider, than i did set it to the public ip of my router and installed a software on my local server to keep the ip up to date:

Okay, so there is a public ip-address shown? If yes, please try to override the ip-address in the docker run command as I’ve pointed out!

Apart from that, there will be an option to skip the domain validation in the future. See allow to skip the domain verification and add documentation for cloud… by szaimen · Pull Request #873 · nextcloud/all-in-one · GitHub

I’ve tried to override the IP Address but this time i have some other issue blocking my way. It did not start up correctly (even with my previous docker start command). When it starts up I get the following:


I tried to access the web view (as GET states in the logs), but it said bad request.

I decided to format my server and start from scratch, since i do have some more time today but will be buisy the next days.

Thanks for your support!

You probably did not access the AIO interface then using https:// but tried with http://, I suppose…

Yes you were right, now it is accessable :smiley:

The new command with --add-host did work. But since i use a ddns domain i worry, that it will be out of sync with the ip at some point :confused:
I will monitor it.

At least now i know that indeed the internal IP was the problem :slight_smile: And i can access my data again.

This should not be a problem since the mastercontainer should not make any access to your domain itself after the domain validation. So it should be fine if the A record gets outdated after a while :+1:

I’ll add this to the documentation:

Nice, i helped to contribute :tada:

1 Like