Nextcloud AIO on fresh Hetzner VPS

Nextcloud version (eg, 20.0.5): AIO latest
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.04 and 22.04, Debian 11,
Apache or nginx version (eg, Apache 2.4.25): fresh server as reccomended without webserver
PHP version (eg, 7.4): none

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N):

Steps to replicate it:

  1. Spin up a new VPS in Hetzner
  2. Install docker as recommended with curl -fsSL | sudo sh
  3. Run the docker run command as recommended on the link above.
--sig-proxy=false \
--name nextcloud-aio-mastercontainer \
--restart always \
--publish 80:80 \
--publish 8080:8080 \
--publish 8443:8443 \
--volume nextcloud_aio_mastercontainer:/mnt/docker-aio-config \
--volume /var/run/docker.sock:/var/run/docker.sock:ro \


Initial startup of Nextcloud All-in-One complete!
You should be able to open the Nextcloud AIO Interface now on port 8080 of this server!
E.g. https://internal.ip.of.this.server:8080

If your server has port 80 and 8443 open and you point a domain to your server, you can get a valid certificate automatically by opening the Nextcloud AIO Interface via:
[Mon Aug 14 09:55:06.038051 2023] [mpm_event:notice] [pid 108:tid 139719985318728] AH00489: Apache/2.4.57 (Unix) OpenSSL/3.1.1 configured – resuming normal operations
[Mon Aug 14 09:55:06.038660 2023] [core:notice] [pid 108:tid 139719985318728] AH00094: Command line: ‘httpd -D FOREGROUND’
[14-Aug-2023 09:55:06] NOTICE: fpm is running, pid 112
[14-Aug-2023 09:55:06] NOTICE: ready to handle connections
{“level”:“info”,“ts”:1692006906.0545876,“msg”:“using provided configuration”,“config_file”:“/Caddyfile”,“config_adapter”:“”}

Expected result:

Nextcloud aio interface should open on https://internal.ip.of.this.server:8080 but it does not.

Tried it with multiple fresh servers and different distros and the same result.

Any idea what can cause this problem. There no error logs also.

Thank you!

A few things come to my mind…

  • Did you enable the Hetzner firewall? If yes, make sure that all the required ports are open / allowed.
  • Did you connect your VPS to a private network in the Hetzner Cloud Console? If yes, you can’t use that address directly from the public internet. You have to use the public IP address of your VPS.
  • If you don’t have set up a domain name yet, try using https://<PUBLIC_IP_OF_YOUR_VPS>:8080 in order to get to the AIO interface.
  • If you have already set up a domain, try https://subdomain.yourdomain.tld:8443

@bb77 Thank you so much! All i had to do is add port 8080 on Hetzner firewall.


@bb77 I can not really thank you enough.

This had blocked me for 5 days. I was trying to debugg nginx and onlyoffice, never considering Hetzner firewalls and my rent was depending on the deadline i had today.

And most importantly another organisation is using Nextcloud now.

Hugs from far away! <3

p.s sorry for bumping this thread but i needed to express my appreciation.


No worries. I’m glad I could help! And I do appreciate the appreciation… :slight_smile:

1 Like