Nextcloud AiO not starting after changing external mount directory. Stuck on Backup

Hi everyone,

I recently encountered an issue with one of my hard drives; it failed and it was designated as an external mount in Nextcloud, not the data directory drive. After replacing the failed drive, I updated the mountpoint to a different HDD. However, I’m facing a problem when trying to launch Nextcloud AiO: it perpetually displays “Daily Backup currently running” but doesn’t proceed.

The Docker logs didn’t provide much insight, only showing the initiation of the daily backup script followed by repeated messages of “Waiting for apache to become available.”

Possible Cause: I suspect the backup directory might have been on the failed hard drive, which could be why the backup process is stalling.

My Question: How can I manually update the backup directory location in Nextcloud AiO if I am unable to access the AiO settings due to this issue?

I am currently using the latest AiO image on an Ubuntu server via Docker. Any advice or suggestions would be greatly appreciated!

Thanks in advance for your help!

Screenshot from 2024-04-23 13-11-56

Edit: Just tried entered the container with docker exec -it nextcloud-aio-mastercontainer and changed my borg_backup_host_location in /mnt/docker-aio-config/data/configuration.json manually to my new hard drive (where I also have a recovered backup). Sadly there is no change, still stuck on “Daily backup currently running.”. There is nothing using CPU in htop either so I doubt it’s doing anything.

Hi, in order to make the aio interface woek again, you need to remove the daily_backup_running file from the mastercontainer volume. It is stored in the data folder inside that.

1 Like

Wow thank you for the quick reply! That got me back to the main AiO menu, looking like this:

Now my nextcloud container is not starting for some reason though… No errors in the log from what I can see:

Connection to nextcloud-aio-database ( 5432 port [tcp/postgresql] succeeded!
 2024-04-22 04:01:48.722681+00
(1 row)

+ '[' -f /dev-dri-group-was-added ']'
++ find /dev -maxdepth 1 -mindepth 1 -name dri
+ '[' -n '' ']'
+ set +x
Enabling Imagick...
WARNING: opening from cache No such file or directory
WARNING: opening from cache No such file or directory
Applying one-click-instance settings...
System config value one-click-instance set to boolean true
System config value one-click-instance.user-limit set to integer 100
System config value set to string
support already enabled
Adjusting log files...
System config value upgrade.cli-upgrade-link set to string
System config value logfile set to string /var/www/html/data/nextcloud.log
Config value logfile for app admin_audit set to /var/www/html/data/audit.log
System config value updatedirectory set to string /nc-updater
Applying network settings...
System config value allow_local_remote_servers set to boolean true
System config value davstorage.request_timeout set to integer 3600
System config value trusted_domains => 1 set to string
System config value overwrite.cli.url set to string
System config value htaccess.RewriteBase set to string /
.htaccess has been updated
System config value dbpersistent set to boolean false
System config value files_external_allow_create_new_local set to boolean true
System config value trusted_proxies => 0 set to string
System config value trusted_proxies => 1 set to string ::1
Config value base_endpoint for app notify_push set to
+ echo nextcloud-aio-collabora
+ grep -q 'nextcloud-.*-collabora'
+ set +x
Config value wopi_url for app richdocuments set to
No ipv6-address found for
Config value wopi_allowlist for app richdocuments set to [publicip],,,,,fd00::/8,::1
Config value recording_servers of app spreed deleted
System config value enabledPreviewProviders => 0 set to string OC\Preview\Imaginary
System config value preview_imaginary_url set to string http://nextcloud-aio-imaginary:9000
System config value preview_imaginary_key set to string 90679b510037bded9d3e1225d34229c69fe7d9773f24bf87
+ '[' true = true ']'
+ '[' 11000 = 443 ']'
+ '[' = ']'
++ dig nextcloud-aio-apache A +short +search
++ grep '^[0-9.]\+$'
++ head -n1
++ sort
++ dig nextcloud-aio-apache AAAA +short +search
++ grep '^[0-9a-f:]\+$'
++ sort
++ head -n1
++ dig nextcloud-aio-mastercontainer A +short +search
++ grep '^[0-9.]\+$'
++ head -n1
++ sort
++ dig nextcloud-aio-mastercontainer AAAA +short +search
++ grep '^[0-9a-f:]\+$'
++ head -n1
++ sort
+ sed -i 's|^;listen.allowed_clients|listen.allowed_clients|' /usr/local/etc/php-fpm.d/www.conf
+ sed -i 's|listen.allowed_clients.*|listen.allowed_clients =,::1,,,,|' /usr/local/etc/php-fpm.d/www.conf
+ sed -i '/^listen.allowed_clients/s/,,/,/g' /usr/local/etc/php-fpm.d/www.conf
+ sed -i '/^listen.allowed_clients/s/,$//' /usr/local/etc/php-fpm.d/www.conf
+ grep listen.allowed_clients /usr/local/etc/php-fpm.d/www.conf
listen.allowed_clients =,::1,,
+ set +x
[22-Apr-2024 07:02:10] NOTICE: fpm is running, pid 388
[22-Apr-2024 07:02:10] NOTICE: ready to handle connections
Activating Collabora config...
✓ Reset callback url autodetect
Checking configuration
🛈 Configured WOPI URL:
🛈 Configured public WOPI URL:
🛈 Configured callback URL: 

✓ Fetched /hosting/discovery endpoint
✓ Valid mimetype response
✓ Valid capabilities entry
✓ Fetched /hosting/capabilities endpoint
✓ Detected WOPI server: Collabora Online Development Edition

Collabora URL (used for Nextcloud to contact the Collabora server):
Collabora public URL (used in the browser to open Collabora):
Callback URL (used by Collabora to connect back to Nextcloud):
  autodetected (will use the same URL as your user for browsing Nextcloud)

I see. You should be able to now fix this by running sudo docker stop nextcloud-aio-apache. Afterwards reload the aio interface. Then all the buttons like stopping and starting etc. Should work again.

Man I have never gotten more effective tech support. Thank you so much, all works again!!

1 Like