Nextcloud-aio-memories througs failed to fetch go-vod?arch=aarch64

I have installed nextcloud aio on a raspberrypi 5 and enabled the memories container. It seems to work but on the logs i got the following errors


Failed to fetch https://domain.tld/index.php/apps/memories/static/go-vod?arch=aarch64
Are you sure the host is reachable and running Memories v6+?
Retrying in 10 seconds...

On manually requesting the above file its accessible.
How can i get rid of that error message?

Hi, is Collabora and Talk working for you?

I am not using both of them so i dont know, but Fulltextsearch & Imaginary as optional containers are working.

Can you do the following?

Run the following commands on your server:

# Go into the container
sudo docker exec -it nextcloud-aio-nextcloud bash
# Now inside the container
curl -vvv https://$NC_DOMAIN:443/login

And post the output here?

pi@raspberrypi5:~ $ sudo docker exec -it nextcloud-aio-nextcloud bash
c02b88c419e7:/var/www/html# curl -vvv https://$NC_DOMAIN:443/login
* Host domain.tld:443 was resolved.
* IPv6: (none)
* IPv4: x.x.x.x
*   Trying x.x.x.x:443...
* connect to x.x.x.x port 443 from port 59318 failed: Connection refused
* Failed to connect to domain.tld port 443 after 235 ms: Couldn't connect to server
* Closing connection
curl: (7) Failed to connect to domain.tld port 443 after 235 ms: Couldn't connect to server

i replaced the domain and ip. The domain + url is accessible if i try it in a browser. Domain check is disabled on startup with --env SKIP_DOMAIN_VALIDATION=true.

It looks like the domain is not reachable feom inside the container, probably due to your router blocking access. You can fiy it with a local dns Server. See

Hi, i would like to join this conversion because I have the same problem but a different setup.

I have the official nextcloud docker image up and running from inside a proxmox vm and access it only from my local network. For the operating system I use the latest ubuntu server lts. I access nextcloud trough a reverse proxy (nginx proxy manager) which also runs on docker and uses a self signed wildcard certificate for all my services.

For this to happen I have a dns server running on a proxmox lxc to route all my local domains to the right ip’s.

But alltough this setup seems absolutely logical to me, the go-vod container cannot connect to the nextcloud container and gives back the same error as mentioned above. Of course I set the env command for self signed certificates to 1 as mentioned in the memories doc. By the way I can access and login my nextcloud instance without having any problem.

I tried the curl command mentioned by szaimen inside the go-vod and also the nextcloud container and it seems that the dns server is doing its thing the right way, of course the ssl handshake fails due to the self signed certificate.

How can I get this thing to work? I would love the have hw acceleration working in memories, its a nice piece of software.


I think I’ve come a little closer to the source of the error. After I opened port 80 on the Nextcloud container and pointed from the go-vod container directly to the nextcloud ip addres it can now connect to Nextcloud and load the binaries without any problems. So the problem is with Nginx Proxy Manager.

Do I need to put some extra lines to the advanced tab on nginx?