Nextcloud-AIO local setup - stuck!

Nextcloud version (eg, 20.0.5): Nextcloud AIO using :latest tag
Operating system and version (eg, Ubuntu 20.04): Ubuntu 22.04.3 LTS

I want to setup Nextcloud AIO so that I can access it ONLY on my local network. I saw the instructions here: all-in-one/ at main · nextcloud/all-in-one · GitHub and was thinking that I had two options to choose:

  1. The recommended way (Option 1)
  2. Buy a certificate and use that (Option 4) - as a side note, when I bought my domain name, I bought an SSL certificate as well. Hoping this will help me achieve this.

Based on my understanding of both options I realised that my first step was to setup a reverse proxy and for this I used Nginx Proxy Manager. Here is the first place where I got unstuck. I followed the instructions as per this location: and filled out the New Proxy Host config as per the screenshots but when I got to the last page and hit Save I was presented with an error: Internal Error.

I thought I’ll come back to fix it later and then fired up the Nextcloud AIO docker-compose config in Portainer. For this I used the docker-compose config located here: all-in-one/compose.yaml at main · nextcloud/all-in-one · GitHub

As I was hoping to run it “behind” a reverse proxy I disabled the 80:80 port mapping. But however, inspite of doing that I was getting errors that Nextcloud AIO couldn’t start since port 8000 was already assigned.

It is true that 8000 is already used - Portainer uses it, but I couldn’t for the life of me see where Nextcloud AIO wanted to use port 8000? I thought it only needs 8080 and 8443? So I’m not sure why it needs port 8000? I also just remembered, that as a test, I just fired Nextcloud AIO from the docker-compose right at the beginning - before I tried any of the above. That time I got to the point of entering my domain. So I thought may be there’s some configuration in the docker container, so I even deleted the container. Still no luck - Nextcloud AIO was still asking for port 8000 to be free.

Given I couldn’t even start Nextcloud AIO with a reverse proxy, I had seen on a few posts the use of the environment variable: SKIP_DOMAIN_VALIDATION so I thought this would help me and set it to true.

Once I did this, the serviced fired up without an issue but then it automatically asked me for a login password. I tried the usual standard ones: admin, password, nextcloud - nothing worked. Then I found this link that gave a command to retrieve the password from the configuration.json file.: How to re-obtain/retreive the Nextcloud AIO password? · nextcloud/all-in-one · Discussion #1786 · GitHub

Went to the folder described in the link above - no configuration.json file. Then I trawled through the documentation for the Nextcloud docker container and set the NEXTCLOUD_ADMIN_PASSWORD - environment variable - no luck. Also then set an admin user, still no luck.

I’ve tried to see if there’s any guides out there that help with setup, but couldn’t find any. Would be great if someone could please give me a hand and steer in the right direction.