Nextcloud AIO - local network only

Dear community,

i am currently dealing with the installation of Nextcloud AIO-mastercontainer, where i unfortunately have problems.


  • Nextcloud AIO should only run in the local network

My setup looks like this:

  • Unraid server with nextcloud-aio-mastercontainer
  • Pi-Hole is installed on the Unraid server and currently acts as a DHCP server

I’m sorry to open a new topic for this again, but i’m really stuck here.

The container itself is running but at the first point of the installation there are problems with domain validation as i only want to use a local domain.

In Pi-Hole, under DNS i already tried to set up the domain with reference to the associated IP address of the container. If the internal domain is entered in the browser, it can be resolved, but the setup does not recognize the domain.

I have also tried to set the parameter -e SKIP_DOMAIN_VALIDATION=true, then the setup runs through. But after that i have no access to the user interface of Nextcloud (port 8443).

By now i have spent several hours on this, i would now ask for your help. I have already seen several tutorials on this forum or on Github, but the implementation was unfortunately without success.

How can i properly implement the domain detection step with a local domain, without an official domain?

Would be grateful for any help! Many thanks in advance!

Kind regards

Hi, see all-in-one/ at main · nextcloud/all-in-one · GitHub

Hi @szaimen, thanks for your reply!

I know this page and wanted to implement the first variant (recommended variant), but without success. I use the NGIX Proxy Manager.

  1. Set up your domain correctly so that it points to your home network.

Which domain should be entered in the NGIX Proxy Manager if there is only the internal domain (for which Letscrypt will not create a certificate)?

  1. Set up a reverse proxy by following the reverse proxy documentation, but only open port 80 (which is needed for the ACME challenge - however no real traffic will use this port).

I did this, but it doesn’t work because of the first step.

  1. Set up a local DNS server like a Pi hole and configure it as your local DNS server for the whole network. Then in the Pi-Hole interface, add a custom DNS record for your domain and overwrite the A record (and possibly the AAAA record) to point to the local IP address of your reverse proxy (see GitHub - nextcloud/all-in-one: Nextcloud AIO stands for Nextcloud All In One and provides easy deployment and maintenance with most features included in this one Nextcloud instance.).

In Pi-Hole under DNS settings, i have stored the domain along with the IP address of the container.

  1. Enter the IP address of your local DNS server in the deamon.json file for Docker so that you are sure that all Docker containers use the correct local DNS server.

Haven’t done this yet as step one and two don’t work correctly.

  1. Entering the domain in the AIO interface should now work as expected and you can proceed with the setup.

That would be great :slight_smile:

Hi, so as in the documentation stated is a valid certificate and thus also public domain required for AIO. However there have been people suceeding in installing with self-signed certificate but this is not supported by AIO because some of the features will not work out-of-the-box and thus also not officially documented. If you look into Discussions · nextcloud/all-in-one · GitHub you might find one of the discussions about this.