Nextcloud AiO Installation - Problem with Port 443/tcp

Greetings all together,

first of all: I’m new to Nextcloud and Docker, so please be patient :slight_smile:
I tried to install Nextcloud on my home desktop to make use of the storage in the setup and a few Nextcloud modules I’m interested in. I stumbled across a few problems I could resolve myself, but now I’m stuck at the Domain validation.

My setup
*Vodafone Docsis 3.1
*Port-Forwarding to my Desktop: 443:443; 80:80
*DynDNS for a free Domain from DuckDNS/
*Static Internal IP for my Desktop

*openSUSE Tumbleweed with AppArmor
*1Tb HDD mounted at /var/lib/docker
*Docker installed

What I did so far:
*copying the instructions from the Nextcloud website and running them in a terminal
*logging in via my my internal IP:
*saving the master password and trying to validate my Domain
*Now I get an error that looks like this (I weren’t able to recreate it due to the further testing I did): Port 443/tcp is not reachable. Please make sure port 443/tcp is open in your firewall/router.

Failed Solution Attempts
Solution Approach 1 (opening the desktop firewall):
*opening the Yast2 Firewall Module and writing 443 into the tcp ports for the docker-zone
*as recommended at the Nextcloud website I switched to IP tables
*I tried to ping my Desktops Wan IP, which worked, but nmap [Domain] 443 issued:
Starting Nmap 7.94 ( ) at 2024-05-21 03:51 CEST
Nmap done: 2 IP addresses (0 hosts up) scanned in 8.95 seconds
result: Nothing worked better

Solution Approach 2 (skip Domain Validation):
*add the skip Domain Validation Variable
*it worked and I proceeded to the next step after entering my Domain
*After selecting the modules I wanted I clicked Install upon which I got the Message: Server not reachable
result: Things got more messy. Now every Container, even all the modules are running totally fine, but I can`t access them.

Solution Approach 3 (back to normal?):
*I wanted to proceed as usually and wibed all the containers and images with docker rm * and docker rmi * and it worked
*I started the container without the skip the Domain Validation Variable to reproduce the first errors, but I as soon as I logged in I wasn’t presented with the option to enter my Domain, but to restart the container I removed earlier.
*after starting them up they were back again, but even as the message Nextcloud is running I still couldn’t access them.
result: I have no clue what to try next…

My goal for now is just getting this up and running optimally without shutting down every firewall in the way.
If you can I would appreciate your help or ideas I could try :slight_smile:


Maybe it’s because of duckdns. I had problems with it and switched to a domain, which is connected to my up over dyndns and wich is ran by a provider.