Nextcloud AIO Containers won't start

Hi all,

So I’ve just used Azure to provision Nextcloud AIO. The Azure marketplace had a pre-packaged solution that I was able to provision as per the below image:

It’s installed. I’ve given it an external IP address and I’ve setup DNS to point to that IP address. I’ve managed to browse to the web interface and perform the initial config where it asks for the URL of your install, and all the DNS has passed.

I’m now at the stage where I can go ahead and start the containers for the first time, however, when I do this, Apache and Nextcloud seem to get stuck in a “starting” state.


Looking for the logs on Apache, I get this:

nc: getaddrinfo for host “nextcloud-aio-nextcloud” port 9000: Temporary failure in name resolution
Waiting for Nextcloud to start…

Looking for the logs on Nextcloud, I get this:

Configuring Redis as session handler…
Setting php max children…
The www-data user doesn’t seem to have access rights in the datadir.
Did you maybe change the datadir and did forget to apply the correct permissions?
See GitHub - nextcloud/all-in-one: The official Nextcloud installation method. Provides easy deployment and maintenance with most features included in this one Nextcloud instance.
The found permissions are:
0:0 755
(userID:groupID permissions)
but they should be:
33:0 750

You’ll have to forgive me, because my Linux knowledge and CLI knowledge is pretty much 0 when it comes to Linux, so this really will be an ExplainItLikeIm5 moment…

I’ve tried to go into /var/lib/docker but it tells me my permissions are denied. When you provision on Azure it makes you choose an admin account that is different to “root”. So I am using that account, Azure doesn’t seem to provide the details for the root account, although the Docker folder is owned by Root. Not sure if this matters, but it was just an observation.

Any help or advice here is appreciated.

Hi, can you run

sudo chown -R 33:0 /mnt/ncdata && sudo chmod -R 750 /mnt/ncdata

and check if it fixes the issue?

1 Like

That seemed to have fixed it. Can I ask what would have been the cause here?

Thanks for your help.

I am not sure honestly. It worked the last time I tested it. But glad that you were able to solve it!

1 Like

I’ve received a similar problem which Apache and Nextcloud kept “starting”, and the solution provided by @szaimen didn’t work for me.
I found that wrong time zone setting had caused this. I’ve input an inexistent time zone. Hope this will help.

I have this issue but it only occurred after I added s3 as an external storage backend. I then received udp buffer errors from cloudflare, increased that buffer, restarted all containers through AIO console and now can’t start Apache or Nextcloud instance.

Can you post the container logs here?

it seems i have the same issue but using windows 10 pro and doker. How to fix it there ?