Nextcloud 28 - Prevent Dashboard From Opening Page in New Tab?

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

This is a follow-on to https://help.nextcloud.com/t/nc-20-0-1-prevent-dashboard-from-opening-new-tab/97869 closed because someone replied to an old thread - but that thread was never answered and no resolution was posted.

Nextcloud version (eg, 20.0.5): 28.0.4

Archlinux: 6.8.9-arch1-1
Apache: 2.4.59 (Unix)
OpenSSL: 3.3.0
PHP: 8.2.19

The issue you are facing:

This is exactly as specified in the earlier post. When you log into nextcloud you get the dashboard. The problem is that when you click anything in the dashboard (e.g. upcoming calendar event, etc…), nextcloud launches the request page in a New Tab instead of using the current tab. The original post was about chromium, but it works the same in Firefox.

How can I configure the dashboard to not do this? I want to use the current tab for the requested page. Nextcloud is heavy enough without adding to the load be having multiple tabs to the same instance running. If I want a new tab, all I have to do is [ctrl + click], but I can’t find a way to make nextcloud not launch a new tab from dashboard.

The menu works just the opposite. It does use the current tab when a new page is selected. The behavior between the menu and dashboard is annoyingly inconsistent in that regard.

Is this the first time you’ve seen this error? No: It’s not an error just annoying unwanted target="_blank" behavior.

Steps to replicate it:

  1. Open dashboard
  2. Click on a link it creates (upcoming even, task etc…)
  3. A new tab is opened in the current browser instead of reusing the current.

None of the config is really relevant to this issue, but I’m happy to post it if you think so. Let me know.

You can upvote the enhancement issue here: https://github.com/nextcloud/server/issues/40717

I can never ignore a person with initials JTR. Will do and hopefully we can at least get a settings option to configure this.