Nextcloud 28: Files are not accessible when username consists of digits

Support intro

Nextcloud version (eg, 20.0.5): Clean
Operating system and version (eg, Ubuntu 20.04): Raspberrypi OS Bookworm
Apache or nginx version (eg, Apache 2.4.25): nginx/1.22.1
PHP version (eg, 7.4): 8.2.7

The issue you are facing:

Users with usernames like ‘12345678’ have no access to files and folder (‘no files in here’), although Dashboard app sees them. Button ‘Add’ is also unaccessible (‘You don’t permission…’). Nothing at logs.

After 3 days of installing/wiping nextcloud and other components, checking data folder permissions and so on I have found that usernames like ‘john’ work like they should.

Does anybody know the solution? Or it is a bug?

1 Like

Hello, I probably hit the same problem. Are you using LDAP for users? If you create new user with digits, is it working?

Edit: It is confirmed. Username with only digits cannot acces files anymore. Same users with atleast one character are working OK.

1 Like

It is a bug: [Bug]: No more files after update to 28.0.2 · Issue #43269 · nextcloud/server · GitHub

Edit: It seems that you are right. Anyone know how to make patch from that fix? Next release will be in two weeks :frowning:

Maybe the only solution for the moment is to create new users with not only digits.

Not if you have 500 LDAP users :frowning:

Sure! But what do you do if you have a lot of shares with users?

That is simply too much work for too much users.

Agree. Sorry, only 3 users in my instance. I used phonenumbers as usernames before and had a painful headache while trying to understand where I was wrong.

There is a note in the original bug report that suggests a downgrade to v28.0.1 is okay in this case because the db structure did not change.

I have just tried this method, but I lost access to the instance. I see only page, which advice me to update.

Correct. Downgrade to 28.0.1 is working ok. You can also download fresh 28.0.1 and copy config.php + fix permision + change version in config.php

1 Like

Today tried once more and was successful. Can confirm that 28.0.1 has no this problem. But I had to reinstall almost all non-standart apps.

I can confirm that rollback to 28.0.1 was successful. But unfortunatelly there is the problem with upload via drag’n drop :frowning: So we will wait until next update 28.0.3.

I can confirm 28.0.1 has problem with Drag and Drop while 28.0.2 is working ok (have 2 instances).

You can install the 28.0.3RC1

All our users have digits only in the username :-(. For the time being we are working with the following workarounds:

  • apps
  • webdav
  • or in the browser: select all folders in Shares->Shared with you and add them to the Favorites. In the Favorites, you can work with them as usual.

Is the bug reported afterall?

Yes, it is fixed in 28.0.3RC1.

1 Like